fix bug #44185 - fails on parallel make; spelling fixes
authorMichael Sterrett <mr_bones_@gentoo.org>
Wed, 10 Mar 2004 00:24:59 +0000 (00:24 +0000)
committerMichael Sterrett <mr_bones_@gentoo.org>
Wed, 10 Mar 2004 00:24:59 +0000 (00:24 +0000)
games-engines/exult/ChangeLog
games-engines/exult/Manifest
games-engines/exult/exult-1.1.10_rc2.ebuild

index c6dce620e70c0f1f45789e837514d55c61540283..d9f6de81330035536194abd689f9e18b9a9a815b 100644 (file)
@@ -1,6 +1,10 @@
 # ChangeLog for games-engines/exult
-# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-engines/exult/ChangeLog,v 1.4 2004/03/06 04:40:50 vapier Exp $
+# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-engines/exult/ChangeLog,v 1.5 2004/03/10 00:24:59 mr_bones_ Exp $
+
+  09 Mar 2004; Michael Sterrett <mr_bones_@gentoo.org>
+  exult-1.1.10_rc2.ebuild:
+  fix bug #44185 - fails on parallel make; spelling fixes
 
 *exult-1.1.10_rc2 (05 Mar 2004)
 
index f84412af327cdd40f5920b5e8f598c06da113030..6bd70cfae8b77c107c69916ec647adcc65c01b66 100644 (file)
@@ -1,4 +1,6 @@
-MD5 a29f8178bad0785bd01d56ccbd0d3a08 ChangeLog 613
-MD5 4c87fe7ea1bc0135bb5f649b3779dab3 exult-1.00.ebuild 1479
-MD5 a30c9d4ce8f9629d6d7323eaab258343 metadata.xml 241
+MD5 3ece888b87f67bb70369a8bf0ef700bd ChangeLog 915
+MD5 a43391d478879d8c37367b2940349508 exult-1.00.ebuild 1483
+MD5 f17b9b8fa07a38914fe1c03268f51678 metadata.xml 158
+MD5 1f8fee9b4ce02aac35200400a4506508 exult-1.1.10_rc2.ebuild 1932
 MD5 15021c85a44b5c6ef41f11d93a003231 files/digest-exult-1.00 63
+MD5 5e69a58420e75805cbf0f8117a85cfd2 files/digest-exult-1.1.10_rc2 68
index baa76b24b6bd38d1cc8a9840515530bb4dedddb5..7f5d09b3bb72c88c7de3349a31b911729dba319d 100644 (file)
@@ -1,6 +1,6 @@
 # Copyright 1999-2004 Gentoo Technologies, Inc.
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-engines/exult/exult-1.1.10_rc2.ebuild,v 1.1 2004/03/06 04:40:50 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-engines/exult/exult-1.1.10_rc2.ebuild,v 1.2 2004/03/10 00:24:59 mr_bones_ Exp $
 
 inherit games
 
@@ -23,9 +23,9 @@ S=${WORKDIR}/${MY_P}
 
 pkg_setup() {
        ewarn "*********************************************************"
-       ewarn " I had massive problems with exult when using agressive"
+       ewarn " I had massive problems with exult when using aggressive"
        ewarn " CFLAGS and CXXFLAGS. If exult segfaults try less"
-       ewarn " agressive optimizations and/or a different -march"
+       ewarn " aggressive optimizations and/or a different -march"
        ewarn " e.g.: -march=i386 instead of -march=i686 on x86"
        ewarn "*********************************************************"
 }
@@ -39,19 +39,20 @@ src_compile() {
                `use_enable mmx` \
                `use_enable 3dnow` \
                || die
-       emake || die
+       # bug #44185 - fails on parallel make
+       emake -j1 || die "emake failed"
 }
 
 src_install() {
-       make DESTDIR=${D} install || die "make install failed"
-       mv ${D}/${GAMES_DATADIR}/{applications,icons} ${D}/usr/share/
+       make DESTDIR="${D}" install || die "make install failed"
+       cp -R "${D}/${GAMES_DATADIR}"/{applications,icons} "${D}/usr/share/" \
+               || die "cp failed"
        dodoc AUTHORS ChangeLog NEWS FAQ README README.1ST
        prepgamesdirs
 }
 
 pkg_postinst() {
-       einfo "To hear music in exult,"
-       einfo "you have to install a timidity-patch."
+       einfo "To hear music in exult, you have to install a timidity-patch."
        einfo "Try this:"
        einfo "         $ emerge timidity-eawpatches"
        einfo "kernel drivers. Install alsa instead."