gui-wm/sway: 1.2 - fix dep on wlroots
authorMatthew Thode <prometheanfire@gentoo.org>
Sun, 12 Jan 2020 01:16:10 +0000 (19:16 -0600)
committerMatthew Thode <prometheanfire@gentoo.org>
Sun, 12 Jan 2020 01:16:29 +0000 (19:16 -0600)
Fixes: https://bugs.gentoo.org/705214
Package-Manager: Portage-2.3.84, Repoman-2.3.20
Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
gui-wm/sway/sway-1.2.ebuild

index 7688622a241878dcdd3e09bb95fbadb01a7892ad..30f010c8638b1fbac4adc450213a049c4580b4b5 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=7
@@ -44,7 +44,10 @@ DEPEND="
 if [[ ${PV} == 9999 ]]; then
        DEPEND+="~gui-libs/wlroots-9999:=[elogind=,systemd=,X=]"
 else
-       DEPEND+=">=gui-libs/wlroots-0.7.0:=[elogind=,systemd=,X=]"
+       DEPEND+="
+       >=gui-libs/wlroots-0.7.0:=[elogind=,systemd=,X=]
+       <gui-libs/wlroots-0.9.0:=[elogind=,systemd=,X=]
+       "
 fi
 RDEPEND="
        x11-misc/xkeyboard-config