media-libs/mesa: Revbump in order to rebuild against libdrm
authorMatt Turner <mattst88@gentoo.org>
Mon, 13 Apr 2020 16:06:42 +0000 (09:06 -0700)
committerMatt Turner <mattst88@gentoo.org>
Mon, 13 Apr 2020 16:32:44 +0000 (09:32 -0700)
And patch the libdrm version requirement so we don't have this problem
again.

Signed-off-by: Matt Turner <mattst88@gentoo.org>
media-libs/mesa/files/mesa-20.0.4-meson-Specify-the-maximum-required-libdrm-in-dri.pc.patch [new file with mode: 0644]
media-libs/mesa/mesa-20.0.4-r1.ebuild [moved from media-libs/mesa/mesa-20.0.4.ebuild with 99% similarity]

diff --git a/media-libs/mesa/files/mesa-20.0.4-meson-Specify-the-maximum-required-libdrm-in-dri.pc.patch b/media-libs/mesa/files/mesa-20.0.4-meson-Specify-the-maximum-required-libdrm-in-dri.pc.patch
new file mode 100644 (file)
index 0000000..0989752
--- /dev/null
@@ -0,0 +1,33 @@
+From 316b352e946a9993a20f28abc741d34455a957a8 Mon Sep 17 00:00:00 2001
+From: Matt Turner <mattst88@gmail.com>
+Date: Mon, 13 Apr 2020 09:20:18 -0700
+Subject: [PATCH] meson: Specify the maximum required libdrm in dri.pc
+
+When dealing with a regression in libdrm-2.4.101, I masked the package
+in Gentoo. In doing so, we discovered that Mesa's dri.pc specifies a
+version requirement in dri.pc for >= the version of libdrm Mesa was
+built against, thus preventing packages from being rebuilt with the
+older version of libdrm installed.
+
+Let's reduce this version requirement to the latest libdrm required by
+Mesa instead, since libdrm is backward compatible.
+---
+ src/mesa/drivers/dri/meson.build | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/mesa/drivers/dri/meson.build b/src/mesa/drivers/dri/meson.build
+index acf7d2eb128..b09ca16e38a 100644
+--- a/src/mesa/drivers/dri/meson.build
++++ b/src/mesa/drivers/dri/meson.build
+@@ -86,7 +86,7 @@ endif
+ if with_dri
+   dri_req_private = []
+   if dep_libdrm.found()
+-    dri_req_private = ['libdrm >= ' + dep_libdrm.version()]
++    dri_req_private = ['libdrm >= ' + _drm_ver]
+   endif
+   pkg.generate(
+-- 
+2.24.1
+
similarity index 99%
rename from media-libs/mesa/mesa-20.0.4.ebuild
rename to media-libs/mesa/mesa-20.0.4-r1.ebuild
index 18accf194edaad7ebac30bbd6e80b4314ff160b2..a0d7a8ff5ca4091a26fa248bf64b6243cae35875 100644 (file)
@@ -246,6 +246,10 @@ x86? (
        libglvnd? ( usr/lib/libGLX_mesa.so.0.0.0 )
 )"
 
+PATCHES=(
+       "${FILESDIR}"/${P}-meson-Specify-the-maximum-required-libdrm-in-dri.pc.patch
+)
+
 llvm_check_deps() {
        local flags=${MULTILIB_USEDEP}
        if use video_cards_r600 || use video_cards_radeon || use video_cards_radeonsi