app-misc/chkcrontab: bump to 1.7
authorTomas Mozes <hydrapolic@gmail.com>
Mon, 6 Mar 2017 08:18:04 +0000 (09:18 +0100)
committerGöktürk Yüksek <gokturk@gentoo.org>
Thu, 16 Mar 2017 21:33:13 +0000 (17:33 -0400)
Package-Manager: Portage-2.3.3, Repoman-2.3.1

app-misc/chkcrontab/Manifest
app-misc/chkcrontab/chkcrontab-1.7.ebuild [new file with mode: 0644]
app-misc/chkcrontab/metadata.xml

index 9456297b24833bdb80c76638783d5934f37aae20..429db9b98f6635389a6efd4f5da98d5e9ba40ba6 100644 (file)
@@ -1 +1,2 @@
 DIST chkcrontab-1.6.tar.gz 24701 SHA256 be7436d5ece4ad6390365f6edf0f1dc59dfd655a9de3b4699884343ceb150f2e SHA512 249061ecf7c8dc2d2275dcda3048fd00fc2ca85d39dabb2de61a3ab415243bbd1a61222be8c0ddfa66eb36577bb2efb27ba4a0c2a013559dee126c95cc73bd1b WHIRLPOOL 13995293e761930d0d900c3e7fa5b7695fad3416ade96fc34be415a448ca5e5969f5b82889d46041ed801ca2f13e5154a01698d753898ee9027bd9a2c8e6e29f
+DIST chkcrontab-1.7.tar.gz 25088 SHA256 1725172dbdea26f1aef915b9acd7100605e49f8675761900bc0992a227d767b9 SHA512 5236b1996a8d4f5d3861bf3d8a1bafafa271237965721ea4ff61e6712ee4546b9d0484483a0dac25f9d920904f899f2930b46df16d656083b422d95a1d6de0c0 WHIRLPOOL bf89b4a126e3244e2b02ec594e57cc50df802be75427148c326d132e1fcbd3df5346301093860d664ca221cc85e78c65768c2a43108f09de11a7c1fdad8a46fc
diff --git a/app-misc/chkcrontab/chkcrontab-1.7.ebuild b/app-misc/chkcrontab/chkcrontab-1.7.ebuild
new file mode 100644 (file)
index 0000000..97df477
--- /dev/null
@@ -0,0 +1,26 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit distutils-r1
+
+DESCRIPTION="A tool to detect crontab errors"
+HOMEPAGE="https://github.com/lyda/chkcrontab"
+SRC_URI="https://github.com/lyda/chkcrontab/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+python_test() {
+       esetup.py test || die
+}
+
+python_install_all() {
+       doman doc/${PN}.1
+       distutils-r1_python_install_all
+}
index 6bd01bfaf51b45d625ca1275c3c5494988066215..d69c349ca9a7cee466eb0db88a4e853854721604 100644 (file)
@@ -1,16 +1,15 @@
 <?xml version="1.0" encoding="UTF-8"?>
 <!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
 <pkgmetadata>
-       <maintainer type="person">
-               <email>hydrapolic@gmail.com</email>
-               <name>Tomas Mozes</name>
-               <description>Proxy maintainer</description>
-       </maintainer>
-       <maintainer type="project">
-               <email>proxy-maint@gentoo.org</email>
-               <name>Proxy Maintainers</name>
-       </maintainer>
-       <upstream>
-               <remote-id type="github">lyda/chkcrontab</remote-id>
-       </upstream>
+  <maintainer type="person">
+    <email>hydrapolic@gmail.com</email>
+    <name>Tomáš Mózes</name>
+  </maintainer>
+  <maintainer type="project">
+    <email>proxy-maint@gentoo.org</email>
+    <name>Proxy Maintainers</name>
+  </maintainer>
+  <upstream>
+    <remote-id type="github">lyda/chkcrontab</remote-id>
+  </upstream>
 </pkgmetadata>