dev-lang/c-intercal: Fix build with -fno-common.
authorUlrich Müller <ulm@gentoo.org>
Mon, 9 Mar 2020 10:11:39 +0000 (11:11 +0100)
committerUlrich Müller <ulm@gentoo.org>
Mon, 9 Mar 2020 10:14:43 +0000 (11:14 +0100)
Closes: https://bugs.gentoo.org/711902
Package-Manager: Portage-2.3.93, Repoman-2.3.20
Signed-off-by: Ulrich Müller <ulm@gentoo.org>
dev-lang/c-intercal/c-intercal-31.0.ebuild
dev-lang/c-intercal/files/c-intercal-31.0-no-common.patch [new file with mode: 0644]

index fa55b57e11b6800163ec04ad84cac60367f321df..5f04f53c129f50097c8814a25241b90cf1e899d6 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=7
@@ -42,6 +42,7 @@ SITEFILE="50${PN}-gentoo.el"
 
 src_prepare() {
        eapply "${FILESDIR}"/${P}-version.patch
+       eapply "${FILESDIR}"/${P}-no-common.patch
        eapply_user
        eautoreconf
 }
diff --git a/dev-lang/c-intercal/files/c-intercal-31.0-no-common.patch b/dev-lang/c-intercal/files/c-intercal-31.0-no-common.patch
new file mode 100644 (file)
index 0000000..ff409ae
--- /dev/null
@@ -0,0 +1,13 @@
+https://bugs.gentoo.org/711902
+
+--- intercal-0.31-orig/src/perpet.c
++++ intercal-0.31/src/perpet.c
+@@ -85,7 +85,7 @@
+ /* function created by yacc */
+ extern int yyparse(void);
+-int yydebug;
++extern int yydebug;
+ /* compilation options */
+ bool compile_only;    /* just compile into C, don't run the linker */