x11-plugins/wmSun: add EAPI7 ebuild
authorMichael Mair-Keimberger <m.mairkeimberger@gmail.com>
Sun, 8 Jul 2018 11:52:54 +0000 (13:52 +0200)
committerBernard Cafarelli <voyageur@gentoo.org>
Thu, 19 Jul 2018 13:24:40 +0000 (15:24 +0200)
x11-plugins/wmSun/wmSun-1.05-r1.ebuild [new file with mode: 0644]

diff --git a/x11-plugins/wmSun/wmSun-1.05-r1.ebuild b/x11-plugins/wmSun/wmSun-1.05-r1.ebuild
new file mode 100644 (file)
index 0000000..b0fda87
--- /dev/null
@@ -0,0 +1,32 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit toolchain-funcs
+
+MY_P=${P/S/s}
+DESCRIPTION="dockapp which displays the rise/set time of the sun"
+HOMEPAGE="https://www.dockapps.net/wmsun"
+SRC_URI="https://dev.gentoo.org/~voyageur/distfiles/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~mips ~ppc ~sparc ~x86"
+
+RDEPEND=">=x11-libs/libdockapp-0.7:=
+       x11-libs/libX11
+       x11-libs/libXext
+       x11-libs/libXpm"
+DEPEND="${RDEPEND}
+       x11-base/xorg-proto"
+
+S="${WORKDIR}/${MY_P}"
+
+src_compile() {
+       emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}"
+}
+
+src_install() {
+       emake DESTDIR="${D}" PREFIX=/usr install
+       dodoc README {BUGS,TODO}
+}