media-fonts/noto: Bump to newer snapshot
authorPacho Ramos <pacho@gentoo.org>
Wed, 11 Mar 2020 21:30:41 +0000 (22:30 +0100)
committerPacho Ramos <pacho@gentoo.org>
Wed, 11 Mar 2020 21:31:42 +0000 (22:31 +0100)
Package-Manager: Portage-2.3.93, Repoman-2.3.20
Signed-off-by: Pacho Ramos <pacho@gentoo.org>
media-fonts/noto/Manifest
media-fonts/noto/noto-20200308.ebuild [new file with mode: 0644]

index 14689b730dda7f4779701caf6804341055a775c8..3454abaab5ed922ec740bca3135c282afd526635 100644 (file)
@@ -1,3 +1,4 @@
 DIST noto-20170403.tar.xz 11083152 BLAKE2B 8281cc19a100d1cbf7f57fba9cba077bb0005f7296f58d48247bef6c804b53597ff359dfab7b7d851e42c0294c757f311979b98dc9f1c22e2d3f3fabe4db77e7 SHA512 f8f1414b5b6f793e86ef3cc6a6320c4545f079b337c7672cb8cccc3c50d21d353d81557da4a555cdb6524c79be3e4c167f7d5aac102c38d64926f3b1887ca7f3
 DIST noto-20181024.tar.gz 726721580 BLAKE2B d19d32d98419395df1bb3ca360bd67a50487d499aa3ea1612355b2f0fef09fe8236583fedc6d528668048ccbeee7139df704fc8e125c5eec7215708838aa09f4 SHA512 5df8266fab59a9ad5e6de6971c69d2761864c29e8d0e79e16a44177327b73527a37a9d148b63c862bfb5f7507793aab5c4319603f3b8b80e18eb9f203d7a7334
 DIST noto-20190524.tar.gz 740252290 BLAKE2B e169ee60c9a83c13656ebd5dbce32aad183bbebc057035c69723788725a1c14a016c37bea7ccf30fc9d776e421515c2fa03f929b5f7bf95d9e3abb1abbeccbbf SHA512 668f7d015da420b3c32f8c0313037bab731bd915875f476beb47e6c3e8d33a30cd608d2f351194607afbf28f8f3efc1eb5f8470c03fd88a83df33b478fa78147
+DIST noto-20200308.tar.gz 853685953 BLAKE2B 1f25bf1b763161fc246b0a1ed532d4755e4ef441055d92a8a17a05331bbbe47b4f604492e0403088d5aac9a86e42b27354eb7d4c9bc6286853ce1562b7940344 SHA512 9afec0c150beeb2bb27af58b9118da4bf86a21f25b573be3a01186c0295b9d5f51918d9237fafc76a0388c87a2b8fd780ba450fb8b4c3e65addad729e8f56a9f
diff --git a/media-fonts/noto/noto-20200308.ebuild b/media-fonts/noto/noto-20200308.ebuild
new file mode 100644 (file)
index 0000000..4100a27
--- /dev/null
@@ -0,0 +1,46 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit font
+
+DESCRIPTION="Google's font family that aims to support all the world's languages"
+HOMEPAGE="https://www.google.com/get/noto/ https://github.com/googlei18n/noto-fonts"
+
+COMMIT="1c9f53362889d4468fd1193b76c397c208d81da8"
+SRC_URI="https://github.com/googlei18n/noto-fonts/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="OFL-1.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+# Extra allows to optionally reduce disk usage even returning to tofu
+# issue as described in https://www.google.com/get/noto/
+IUSE="cjk +extra"
+
+RDEPEND="cjk? ( media-fonts/noto-cjk )"
+DEPEND=""
+
+RESTRICT="binchecks strip"
+
+S="${WORKDIR}/${PN}-fonts-${COMMIT}"
+
+FONT_SUFFIX="ttf"
+FONT_CONF=(
+       # From ArchLinux
+       "${FILESDIR}/66-noto-serif.conf"
+       "${FILESDIR}/66-noto-mono.conf"
+       "${FILESDIR}/66-noto-sans.conf"
+)
+
+src_install() {
+       mkdir install-unhinted install-hinted || die
+       mv unhinted/*/* install-unhinted/. ||  die
+       mv hinted/*/* install-hinted/. || die
+
+       FONT_S="${S}/install-unhinted/" font_src_install
+       FONT_S="${S}/install-hinted/" font_src_install
+
+       # Allow to drop some fonts optionally for people that want to save
+       # disk space. Following ArchLinux options.
+       use extra || rm -rf "${ED}"/usr/share/fonts/noto/Noto*{Condensed,SemiBold,Extra}*.ttf
+}