media-libs/aribb24-1.0.3-r1: enable multilib, bump to EAPI 7.
authorHector Martin <marcan@marcan.st>
Sun, 10 Feb 2019 02:47:44 +0000 (11:47 +0900)
committerPatrice Clement <monsieurp@gentoo.org>
Sat, 16 Feb 2019 22:29:20 +0000 (23:29 +0100)
Signed-off-by: Hector Martin <marcan@marcan.st>
Package-Manager: Portage-2.3.59, Repoman-2.3.12
Closes: https://github.com/gentoo/gentoo/pull/11014
Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
media-libs/aribb24/aribb24-1.0.3-r1.ebuild [new file with mode: 0644]

diff --git a/media-libs/aribb24/aribb24-1.0.3-r1.ebuild b/media-libs/aribb24/aribb24-1.0.3-r1.ebuild
new file mode 100644 (file)
index 0000000..a6cba52
--- /dev/null
@@ -0,0 +1,31 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools multilib-minimal
+
+DESCRIPTION="Library for decoding ARIB STD-B24 subtitles"
+HOMEPAGE="https://github.com/nkoriyama/aribb24"
+SRC_URI="https://github.com/nkoriyama/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
+
+RDEPEND="media-libs/libpng:0=[${MULTILIB_USEDEP}]"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+src_prepare() {
+       default
+       eautoreconf
+}
+
+multilib_src_configure() {
+       ECONF_SOURCE="${S}" econf --disable-static
+}
+
+multilib_src_install_all() {
+       find "${D}" -name '*.la' -delete || die
+}