dev-libs/jemalloc: use version from mozilla repository
authorThomas Deutschmann <whissi@gentoo.org>
Tue, 11 Jun 2019 23:51:21 +0000 (01:51 +0200)
committerThomas Deutschmann <whissi@gentoo.org>
Tue, 11 Jun 2019 23:51:21 +0000 (01:51 +0200)
Package-Manager: Portage-2.3.67, Repoman-2.3.14
Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
dev-libs/jemalloc/files/jemalloc-5.2.0-fix_html_install.patch [deleted file]
dev-libs/jemalloc/files/jemalloc-5.2.0-gentoo-fixups.patch [new file with mode: 0644]
dev-libs/jemalloc/jemalloc-5.2.0.ebuild

diff --git a/dev-libs/jemalloc/files/jemalloc-5.2.0-fix_html_install.patch b/dev-libs/jemalloc/files/jemalloc-5.2.0-fix_html_install.patch
deleted file mode 100644 (file)
index fe7bcb4..0000000
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/Makefile.in
-+++ b/Makefile.in
-@@ -511,7 +511,7 @@ install_doc_man:
-       $(INSTALL) -m 644 $$d $(MANDIR)/man3; \
- done
--install_doc: build_doc install_doc_html install_doc_man
-+install_doc: build_doc install_doc_man
- install: install_bin install_include install_lib install_doc
diff --git a/dev-libs/jemalloc/files/jemalloc-5.2.0-gentoo-fixups.patch b/dev-libs/jemalloc/files/jemalloc-5.2.0-gentoo-fixups.patch
new file mode 100644 (file)
index 0000000..2e7fd0d
--- /dev/null
@@ -0,0 +1,54 @@
+From 482a28e74f9b3c83bef6499842f1191c04ae80d9 Mon Sep 17 00:00:00 2001
+From: Jory Pratt <anarchy@gentoo.org>
+Date: Tue, 23 Apr 2019 10:04:19 -0500
+Subject: [PATCH] Don't override user cflags, disable html_doc from being
+ installed
+
+Signed-off-by: Jory Pratt <anarchy@gentoo.org>
+---
+ Makefile.in  |  2 +-
+ configure.ac | 15 ---------------
+ 2 files changed, 1 insertion(+), 16 deletions(-)
+
+diff --git a/Makefile.in b/Makefile.in
+index 0777f6a..31767b6 100644
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -511,7 +511,7 @@ install_doc_man:
+       $(INSTALL) -m 644 $$d $(MANDIR)/man3; \
+ done
+-install_doc: build_doc install_doc_html install_doc_man
++install_doc: build_doc install_doc_man
+ install: install_bin install_include install_lib install_doc
+diff --git a/configure.ac b/configure.ac
+index 96f76d3..f716ebd 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -1108,21 +1108,6 @@ if test "x$enable_debug" = "x1" ; then
+ fi
+ AC_SUBST([enable_debug])
+-dnl Only optimize if not debugging.
+-if test "x$enable_debug" = "x0" ; then
+-  if test "x$GCC" = "xyes" ; then
+-    JE_CFLAGS_ADD([-O3])
+-    JE_CXXFLAGS_ADD([-O3])
+-    JE_CFLAGS_ADD([-funroll-loops])
+-  elif test "x$je_cv_msvc" = "xyes" ; then
+-    JE_CFLAGS_ADD([-O2])
+-    JE_CXXFLAGS_ADD([-O2])
+-  else
+-    JE_CFLAGS_ADD([-O])
+-    JE_CXXFLAGS_ADD([-O])
+-  fi
+-fi
+-
+ dnl Enable statistics calculation by default.
+ AC_ARG_ENABLE([stats],
+   [AS_HELP_STRING([--disable-stats],
+-- 
+2.21.0
+
index d2b63f0d039601f39be276d68b1c68e89b92f716..16ced36e7579d8783f50c6f9043d817d4484a261 100644 (file)
@@ -14,9 +14,8 @@ SLOT="0/2"
 KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~x86 ~amd64-linux ~x86-linux ~x64-macos ~x64-solaris"
 IUSE="debug hardened lazy-lock static-libs stats xmalloc"
 HTML_DOCS=( doc/jemalloc.html )
-PATCHES=( "${FILESDIR}/${PN}-5.0.1-strip-optimization.patch"
-       "${FILESDIR}/${PN}-5.2.0-fix_html_install.patch"
-)
+PATCHES=( "${FILESDIR}/${PN}-5.2.0-gentoo-fixups.patch" )
+
 MULTILIB_WRAPPED_HEADERS=( /usr/include/jemalloc/jemalloc.h )
 # autotools-utils.eclass auto-adds configure options when static-libs is in IUSE
 # but jemalloc doesn't implement them in its configure; need this here to