app-admin/cronolog: don't use globbing in PATCHES but in a separate array instead.
authorPatrice Clement <monsieurp@gentoo.org>
Sat, 25 Feb 2017 08:54:50 +0000 (09:54 +0100)
committerPatrice Clement <monsieurp@gentoo.org>
Sat, 25 Feb 2017 08:54:50 +0000 (09:54 +0100)
Globbing in PATCHES causes Portage pain, see:

https://qa-reports.gentoo.org/output/gentoo-ci/b80fba8b4/output.html#app-admin/cronolog

Package-Manager: portage-2.3.3

app-admin/cronolog/cronolog-1.6.2-r5.ebuild

index 121f6cf721a3545f27b90202e86d802ab9732e3a..387ea3582af45dc9b6d6d2e2ac285d40bf7b9b68 100644 (file)
@@ -14,7 +14,7 @@ LICENSE="GPL-2"
 SLOT="0"
 KEYWORDS="~amd64 ~arm ~ppc ~x86"
 
-PATCHES=(
+MY_PATCHES=(
        "${FILESDIR}/${PV}-patches"/*.txt
        "${FILESDIR}/${P}-umask.patch"
 )
@@ -23,6 +23,7 @@ DOCS=( AUTHORS ChangeLog INSTALL NEWS README TODO )
 
 src_prepare() {
        default
+       epatch "${MY_PATCHES[@]}"
        eautoreconf
 }