dev-python/xvfbwrapper: version bump to 0.2.9
authorTim Harder <radhermit@gentoo.org>
Tue, 18 Sep 2018 18:29:23 +0000 (14:29 -0400)
committerTim Harder <radhermit@gentoo.org>
Tue, 18 Sep 2018 21:21:47 +0000 (17:21 -0400)
dev-python/xvfbwrapper/Manifest
dev-python/xvfbwrapper/xvfbwrapper-0.2.9.ebuild [new file with mode: 0644]

index c228edb0f58024ea029a8beaa3bc8bb80f610990..4a4d63051284c44f606b5685ec8bb5723acaebdb 100644 (file)
@@ -1 +1,2 @@
 DIST xvfbwrapper-0.2.8.tar.gz 4660 BLAKE2B 464a9f3d41d3c96a72c0cfc56994c32ccb94ac19267f5a701bd0ee18a17010216fd7ee163d8a532e62fd2256dc296201d4150f4f0d03fd4f20eae703b6bcaac1 SHA512 1b29b7e6bb336a9972e51249bbc96805733e305476cc559f5501cd09a343671c10333b5592e4c4868016d4510b37d6c592165a4683b1543e62c2205b1eeb0980
+DIST xvfbwrapper-0.2.9.tar.gz 5575 BLAKE2B a973e6ca6dd85713e7b350397113d63c15fd284c07d3a0d5c0b8b8dceed65c3a17a3e8222b79ec88fb124175259d51fcd31d09a95183f1cbd091ba11d9bbec3b SHA512 800f3489b2e1bbc884d7651e344ed73783d6c00856f3ab7ccfa6b9058dd6d3bb98d38f11172ba89dff5773d6c5b773bc000786c1f6c6aae5a27179b37017851e
diff --git a/dev-python/xvfbwrapper/xvfbwrapper-0.2.9.ebuild b/dev-python/xvfbwrapper/xvfbwrapper-0.2.9.ebuild
new file mode 100644 (file)
index 0000000..da1a8cb
--- /dev/null
@@ -0,0 +1,25 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Python wrapper for running a display inside X virtual framebuffer"
+HOMEPAGE="https://github.com/cgoldberg/xvfbwrapper https://pypi.org/project/xvfbwrapper/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="x11-base/xorg-server[xvfb]"
+DEPEND="${RDEPEND}
+       test? ( $(python_gen_cond_dep 'dev-python/mock[${PYTHON_USEDEP}]' python2_7) )
+"
+
+python_test() {
+       "${PYTHON}" -m unittest discover || die "Tests failed with ${EPYTHON}"
+}