sys-auth/AusweisApp2: New package
authorVolkmar W. Pogatzki <gentoo@pogatzki.net>
Sat, 23 May 2020 16:22:11 +0000 (18:22 +0200)
committerConrad Kostecki <conikost@gentoo.org>
Mon, 25 May 2020 11:14:03 +0000 (13:14 +0200)
The AusweisApp2 is a software, that you can install on your
Computer/Smartphone/Tablet, to identify yourself online with
your ID card or your electronic residence permit. The App is
availible for the most used operating systems and works in
all common browsers.

Closes: https://bugs.gentoo.org/344941

This package has been in ::guru since several weeks.

Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Volkmar W. Pogatzki <gentoo@pogatzki.net>
Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
sys-auth/AusweisApp2/AusweisApp2-1.20.0.ebuild [new file with mode: 0644]
sys-auth/AusweisApp2/AusweisApp2-9999.ebuild [new file with mode: 0644]
sys-auth/AusweisApp2/Manifest [new file with mode: 0644]
sys-auth/AusweisApp2/metadata.xml [new file with mode: 0644]

diff --git a/sys-auth/AusweisApp2/AusweisApp2-1.20.0.ebuild b/sys-auth/AusweisApp2/AusweisApp2-1.20.0.ebuild
new file mode 100644 (file)
index 0000000..42a6dda
--- /dev/null
@@ -0,0 +1,39 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="Official authentication app for German ID cards and residence permits"
+HOMEPAGE="https://www.ausweisapp.bund.de/"
+SRC_URI="https://github.com/Governikus/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="EUPL-1.2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="virtual/pkgconfig"
+
+RDEPEND="
+       dev-qt/qtcore:5
+       dev-qt/qtnetwork:5
+       dev-qt/qtgui:5
+       dev-qt/qtsvg:5
+       dev-qt/qtwebsockets:5[qml]
+       dev-qt/qtwidgets:5
+       dev-qt/qtdeclarative
+       dev-libs/openssl:0=
+       sys-apps/pcsc-lite
+       net-libs/http-parser:0=
+       virtual/udev"
+
+DEPEND="${RDEPEND}
+       dev-qt/qtconcurrent:5
+       dev-qt/qtquickcontrols2:5
+       dev-qt/linguist-tools:5"
+
+src_configure() {
+       local mycmakeargs=( -DBUILD_SHARED_LIBS=OFF )
+       cmake_src_configure
+}
diff --git a/sys-auth/AusweisApp2/AusweisApp2-9999.ebuild b/sys-auth/AusweisApp2/AusweisApp2-9999.ebuild
new file mode 100644 (file)
index 0000000..774b124
--- /dev/null
@@ -0,0 +1,38 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake git-r3
+
+DESCRIPTION="Official authentication app for German ID cards and residence permits"
+HOMEPAGE="https://www.ausweisapp.bund.de/"
+EGIT_REPO_URI="https://github.com/Governikus/AusweisApp2.git"
+
+LICENSE="EUPL-1.2"
+SLOT="0"
+
+BDEPEND="virtual/pkgconfig"
+
+RDEPEND="
+       dev-qt/qtcore:5
+       dev-qt/qtnetwork:5
+       dev-qt/qtgui:5
+       dev-qt/qtsvg:5
+       dev-qt/qtwebsockets:5[qml]
+       dev-qt/qtwidgets:5
+       dev-qt/qtdeclarative
+       dev-libs/openssl:0=
+       sys-apps/pcsc-lite
+       net-libs/http-parser:0=
+       virtual/udev"
+
+DEPEND="${RDEPEND}
+       dev-qt/qtconcurrent:5
+       dev-qt/qtquickcontrols2:5
+       dev-qt/linguist-tools:5"
+
+src_configure() {
+       local mycmakeargs=( -DBUILD_SHARED_LIBS=OFF )
+       cmake_src_configure
+}
diff --git a/sys-auth/AusweisApp2/Manifest b/sys-auth/AusweisApp2/Manifest
new file mode 100644 (file)
index 0000000..6a730bf
--- /dev/null
@@ -0,0 +1 @@
+DIST AusweisApp2-1.20.0.tar.gz 9727544 BLAKE2B 23d31b5cff2756948d563052ff53fffb737c6895fddada036969350b0a65f404f8def70f8ac4409a34fe9f83160e15cd8d4b6441f901f8e53e791ca386140383 SHA512 9222bc59521aa3533c79206df14b079e618f6efbdd04c11b4cc754027dc155d2ad4a321cabdbb35b9308f5e9631ca05e828969633125fe0ac651156669a784d0
diff --git a/sys-auth/AusweisApp2/metadata.xml b/sys-auth/AusweisApp2/metadata.xml
new file mode 100644 (file)
index 0000000..6c6206d
--- /dev/null
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+       <!-- maintainer-needed -->
+       <upstream>
+               <remote-id type="github">Governikus/AusweisApp2</remote-id>
+       </upstream>
+</pkgmetadata>