Remove old version. Version bump.
authorAlin Năstac <mrness@gentoo.org>
Thu, 16 Nov 2006 21:39:52 +0000 (21:39 +0000)
committerAlin Năstac <mrness@gentoo.org>
Thu, 16 Nov 2006 21:39:52 +0000 (21:39 +0000)
Package-Manager: portage-2.1.1-r1

net-proxy/haproxy/ChangeLog
net-proxy/haproxy/files/digest-haproxy-1.2.16 [new file with mode: 0644]
net-proxy/haproxy/haproxy-1.2.16.ebuild [new file with mode: 0644]

index ea5fc0d8049daea7c8d4695b309fafe3e27b0e78..d778b053e8ed0d451912ed90b981cd5ce9274992 100644 (file)
@@ -1,6 +1,12 @@
 # ChangeLog for net-proxy/haproxy
 # Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-proxy/haproxy/ChangeLog,v 1.3 2006/09/20 11:41:35 mrness Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-proxy/haproxy/ChangeLog,v 1.4 2006/11/16 21:39:52 mrness Exp $
+
+*haproxy-1.2.16 (16 Nov 2006)
+
+  16 Nov 2006; Alin Nastac <mrness@gentoo.org> -haproxy-1.2.14.ebuild,
+  +haproxy-1.2.16.ebuild:
+  Remove old version. Version bump.
 
 *haproxy-1.2.15 (20 Sep 2006)
 
diff --git a/net-proxy/haproxy/files/digest-haproxy-1.2.16 b/net-proxy/haproxy/files/digest-haproxy-1.2.16
new file mode 100644 (file)
index 0000000..1262ca2
--- /dev/null
@@ -0,0 +1,3 @@
+MD5 f72c44bcddf868edf4000503be09a12d haproxy-1.2.16.tar.gz 197867
+RMD160 f9fde12bd4d9ef3397c5f56f6ba679d8d65699c2 haproxy-1.2.16.tar.gz 197867
+SHA256 c8635aaf761f3bb74676d6cbc1ebb415cdcebebcdb46261a737a7d69c4251f2f haproxy-1.2.16.tar.gz 197867
diff --git a/net-proxy/haproxy/haproxy-1.2.16.ebuild b/net-proxy/haproxy/haproxy-1.2.16.ebuild
new file mode 100644 (file)
index 0000000..32ee393
--- /dev/null
@@ -0,0 +1,43 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-proxy/haproxy/haproxy-1.2.16.ebuild,v 1.1 2006/11/16 21:39:52 mrness Exp $
+
+inherit linux-info
+
+DESCRIPTION="A TCP/HTTP reverse proxy for high availability environments"
+HOMEPAGE="http://haproxy.1wt.eu"
+SRC_URI="http://haproxy.1wt.eu/download/1.2/src/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="pcre"
+
+DEPEND="pcre? ( >=dev-libs/libpcre-6.3 )"
+
+src_compile() {
+       local ARGS="TARGET=linux${KV_MAJOR}${KV_MINOR}"
+       use pcre && ARGS="${ARGS} REGEX=pcre"
+       emake ADDINC="${CFLAGS}" LDFLAGS="${LDFLAGS}" ${ARGS}
+}
+
+src_install() {
+       exeinto /usr/bin
+       doexe haproxy
+       newinitd "${FILESDIR}/haproxy.initd" haproxy
+
+       dodoc CHANGELOG ROADMAP TODO doc/*
+       docinto examples
+       dodoc examples/examples.cfg examples/haproxy.cfg
+}
+
+pkg_postinst() {
+       if [[ ! -f "${ROOT}/etc/haproxy.cfg" ]] ; then
+               einfo "You need to create /etc/haproxy.cfg before you start haproxy service."
+               if [[ -d "${ROOT}/usr/share/doc/${P}" ]]; then
+                       einfo "Please consult the installed documentation for learning the configuration file's syntax."
+                       einfo "The documentation and sample configuration files are installed here:"
+                       einfo "   ${ROOT}usr/share/doc/${P}"
+               fi
+       fi
+}