dev-python/webtest: Set DISTUTILS_USE_SETUPTOOLS
authorMichał Górny <mgorny@gentoo.org>
Mon, 27 Jan 2020 06:43:49 +0000 (07:43 +0100)
committerMichał Górny <mgorny@gentoo.org>
Mon, 27 Jan 2020 07:22:17 +0000 (08:22 +0100)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/webtest/webtest-2.0.33.ebuild

index 3f9b7c6ca0e18e7fe3e9661ff5fac54865442795..248cccfad198f2ddd8871f3e86044e43a339b103 100644 (file)
@@ -3,6 +3,7 @@
 
 EAPI=7
 
+DISTUTILS_USE_SETUPTOOLS=rdepend
 PYTHON_COMPAT=( python{2_7,3_{6,7,8}} pypy3 )
 
 inherit distutils-r1
@@ -30,7 +31,6 @@ RDEPEND="
        dev-python/beautifulsoup:4[${PYTHON_USEDEP}]"
 BDEPEND="${RDEPEND}
        app-arch/unzip
-       dev-python/setuptools[${PYTHON_USEDEP}]
        test? ( dev-python/nose[${PYTHON_USEDEP}]
                dev-python/pyquery[${PYTHON_USEDEP}]
                dev-python/pastedeploy[${PYTHON_USEDEP}]