x11-terms/guake: Fix dependencies, runtime
authorJeroen Roovers <jer@gentoo.org>
Sat, 6 Oct 2018 10:22:46 +0000 (12:22 +0200)
committerJeroen Roovers <jer@gentoo.org>
Sat, 6 Oct 2018 10:25:09 +0000 (12:25 +0200)
Bug: https://bugs.gentoo.org/667878
Package-Manager: Portage-2.3.50, Repoman-2.3.11
Signed-off-by: Jeroen Roovers <jer@gentoo.org>
x11-terms/guake/files/guake-3.4.0-paths.patch [new file with mode: 0644]
x11-terms/guake/guake-3.4.0-r1.ebuild [moved from x11-terms/guake/guake-3.4.0.ebuild with 88% similarity]
x11-terms/guake/guake-9999.ebuild

diff --git a/x11-terms/guake/files/guake-3.4.0-paths.patch b/x11-terms/guake/files/guake-3.4.0-paths.patch
new file mode 100644 (file)
index 0000000..30a4729
--- /dev/null
@@ -0,0 +1,14 @@
+https://bugs.gentoo.org/667878
+https://github.com/Guake/guake/issues/1436
+
+--- a/guake/paths.py
++++ b/guake/paths.py
+@@ -35,7 +35,7 @@
+ def get_data_files_dir():
+-    d = os.path.dirname(os.path.dirname(sys.modules["guake"].__file__))
++    d = os.path.dirname(sys.modules["guake"].__file__)
+     p = os.path.basename(os.path.abspath(os.path.join(d, "..")))
+     if p in ["site-packages", "dist-packages"]:
+         # current "guake" package has been installed in a prefix structure (/usr, /usr/local or
similarity index 88%
rename from x11-terms/guake/guake-3.4.0.ebuild
rename to x11-terms/guake/guake-3.4.0-r1.ebuild
index ec3ad80d6f2e7fa799155e546e3b9528b22f08b9..a9aeb41ea1cfdda70cf0b7145f989c8856690168 100644 (file)
@@ -17,13 +17,14 @@ KEYWORDS="~amd64 ~arm ~x86"
 IUSE="utempter"
 
 RDEPEND="
-       dev-libs/keybinder:3
+       dev-libs/glib[${PYTHON_USEDEP}]
+       dev-libs/keybinder:3[introspection]
        dev-python/dbus-python[${PYTHON_USEDEP}]
        dev-python/pbr[${PYTHON_USEDEP}]
        dev-python/pycairo[${PYTHON_USEDEP}]
        dev-python/pygobject:3[${PYTHON_USEDEP}]
-       x11-libs/libnotify
-       x11-libs/vte:2.91
+       x11-libs/libnotify[introspection]
+       x11-libs/vte:2.91[introspection]
        utempter? ( sys-libs/libutempter )
 "
 DEPEND="
@@ -36,6 +37,7 @@ DEPEND="
 
 PATCHES=(
        "${FILESDIR}"/${PN}-3.3.2-paths.patch
+       "${FILESDIR}"/${PN}-3.4.0-paths.patch
 )
 S=${WORKDIR}/${P^}
 
index 46f3706e7f3dfa4ed3b91a6704897695d5421b1b..593f8375adb6ecf111c6e1bf1f917cdd5588fcdb 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=6
@@ -17,13 +17,14 @@ KEYWORDS=""
 IUSE="utempter"
 
 RDEPEND="
-       dev-libs/keybinder:3
+       dev-libs/glib[${PYTHON_USEDEP}]
+       dev-libs/keybinder:3[introspection]
        dev-python/dbus-python[${PYTHON_USEDEP}]
        dev-python/pbr[${PYTHON_USEDEP}]
        dev-python/pycairo[${PYTHON_USEDEP}]
        dev-python/pygobject:3[${PYTHON_USEDEP}]
-       x11-libs/libnotify
-       x11-libs/vte:2.91
+       x11-libs/libnotify[introspection]
+       x11-libs/vte:2.91[introspection]
        utempter? ( sys-libs/libutempter )
 "
 DEPEND="
@@ -36,6 +37,7 @@ DEPEND="
 
 PATCHES=(
        "${FILESDIR}"/${PN}-3.3.2-paths.patch
+       "${FILESDIR}"/${PN}-3.4.0-paths.patch
 )
 
 python_compile_all() {