dev-python/scapy-python3: version bump (0.21)
authorTobias Klausmann <klausman@gentoo.org>
Mon, 17 Jul 2017 07:51:19 +0000 (09:51 +0200)
committerTobias Klausmann <klausman@gentoo.org>
Mon, 17 Jul 2017 07:51:19 +0000 (09:51 +0200)
Package-Manager: Portage-2.3.6, Repoman-2.3.2

dev-python/scapy-python3/Manifest
dev-python/scapy-python3/scapy-python3-0.21.ebuild [new file with mode: 0644]

index add0af4a9865ba5bc4823d7e885eb519baad4400..f378e9bfb1859e5a3bbc487a403c6d99e18d2a31 100644 (file)
@@ -1 +1,2 @@
 DIST scapy-python3-0.18.tar.gz 2052898 SHA256 23c19d0dbba07b7a7681d97784371f92fb570cdea3ae58e12bf19fe98c7bf7ad SHA512 3b39e8cdb60dfd5d1e92eae681eb08f065ba14bbd647d55f3d4f62383a459c217024311c945c3731f1a58fe47e6b525492e760e2e1c8ea6eb807f7d59c975c5b WHIRLPOOL ce5794f4be40250a05855cdaed2370762f113cd0deb6b1d7160b9198b43ecf1f3301593360183974ec2be1efdbe48c25d8fb20fd210a89254aa4739f8ab65ed9
+DIST scapy-python3-0.21.tar.gz 2179545 SHA256 abe65bb75cb9bcabbb69399c548c7981260f06439a1328d87d3d6ed66a978202 SHA512 d1f5eee914a25a7217f187fe8c757d330aa0375e1c90fb2e5f71ffaa2c7f97d0bf7e62f1e5ed9f9b7238a5d467d3c4f7186f5238b6d7444e94d9d98a1a602f76 WHIRLPOOL 848d00f84a84d74887c7bc628acffc7064971e841811516cbbaeb73f3be52234edec2ccff3b87df0cb64eea20a9eea88e431d2682616a18c4af6fa1408add0d3
diff --git a/dev-python/scapy-python3/scapy-python3-0.21.ebuild b/dev-python/scapy-python3/scapy-python3-0.21.ebuild
new file mode 100644 (file)
index 0000000..07ba265
--- /dev/null
@@ -0,0 +1,22 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python3_{4,5} )
+
+IUSE="test"
+inherit distutils-r1
+
+DESCRIPTION="Packet crafting/sending/... PCAP processing tool with python3 compatibility"
+HOMEPAGE="https://pypi.python.org/pypi/scapy-python3/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DEPEND="
+       dev-python/setuptools[${PYTHON_USEDEP}]
+       !net-analyzer/scapy
+       "