app-text/cpdf: version bump to 2.3.1
authorTim Harder <radhermit@gentoo.org>
Fri, 27 Dec 2019 18:46:05 +0000 (11:46 -0700)
committerTim Harder <radhermit@gentoo.org>
Fri, 27 Dec 2019 19:10:32 +0000 (12:10 -0700)
Signed-off-by: Tim Harder <radhermit@gentoo.org>
app-text/cpdf/Manifest
app-text/cpdf/cpdf-2.3.1.ebuild [new file with mode: 0644]

index f4180f33fe84d979bbbff905badbd3a30ad5671d..95ee8d57ffbe3605cf5d7e66d7cb1e14d0ddebb3 100644 (file)
@@ -1,2 +1,3 @@
 DIST cpdf-2.2.1.tar.gz 704730 BLAKE2B 1767d2c9fdc645b4ff97b828b1d7bedb22aa645444f299e36ec4717015ea7b87dbbac4c9ec27bb508a7adb28b2c75c155bf9094a168567abbffa93887712241d SHA512 3dda72513c551cca5d8cb60732b3f2c2e8ad400bd2c9fcf0c3b54a68e94385e3f19ec7713de95efa90eafb7b0077662097565a28616041019e03edf140b6af4f
+DIST cpdf-2.3.1.tar.gz 385720 BLAKE2B fae61c8e62b1c679919512c5fa4c57279e118d7ecc8378b528053a1487731675f47877c6164d92f3770e38db78fd9bcce0635f76f0b2efdf10c775a1e9cf5ed7 SHA512 3f22e76bc6bffe2bcd6b2c27d0aa8dc55b842cf0eee46f23c0f3e23e1a86ac7af4665b48513ae3e2d7d2ae84fc864af3b6c3c92e93d78b7798b801bb9be987a1
 DIST cpdf-2.3.tar.gz 384594 BLAKE2B 391cc2d88ae5ad2decc3911ea2125345cb337e15f059b2411f8e835f91460bc0cb28410ebe8a15bbf3c2c5ba511f89b0bcfec8ccae3aca69658fd6eb55c64dc2 SHA512 db17bd019a6c2a719761662af682cc74a7dbcc673c22867652cef37508b6d3dcbf4d5da9d9db9e8b1b0cf912f03be18f16748ab15dcbdfbdfd37900d4fd04ddd
diff --git a/app-text/cpdf/cpdf-2.3.1.ebuild b/app-text/cpdf/cpdf-2.3.1.ebuild
new file mode 100644 (file)
index 0000000..3df1825
--- /dev/null
@@ -0,0 +1,39 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit findlib
+
+DESCRIPTION="A command line tool for manipulating PDF files"
+HOMEPAGE="https://community.coherentpdf.com/ https://github.com/johnwhitington/cpdf-source/"
+SRC_URI="https://github.com/johnwhitington/cpdf-source/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+# BSD is only for xmlm.ml
+LICENSE="Coherent-Graphics BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+RDEPEND=">=dev-lang/ocaml-4:=[ocamlopt]
+       ~dev-ml/camlpdf-${PV}:="
+DEPEND="${RDEPEND}"
+
+RESTRICT="mirror bindist"
+
+S=${WORKDIR}/${PN}-source-${PV}
+
+src_compile() {
+       # parallel make issues
+       emake -j1
+}
+
+src_install() {
+       findlib_src_install
+
+       dobin cpdf
+       dodoc Changes README.md cpdfmanual.pdf
+       doman cpdf.1
+
+       use doc && dodoc -r doc/cpdf/html
+}