net-analyzer/wapiti: 3.0.3 bump
authorBernard Cafarelli <voyageur@gentoo.org>
Fri, 21 Feb 2020 14:10:15 +0000 (15:10 +0100)
committerBernard Cafarelli <voyageur@gentoo.org>
Fri, 21 Feb 2020 14:11:06 +0000 (15:11 +0100)
Package-Manager: Portage-2.3.89, Repoman-2.3.20
Signed-off-by: Bernard Cafarelli <voyageur@gentoo.org>
net-analyzer/wapiti/Manifest
net-analyzer/wapiti/wapiti-3.0.3.ebuild [new file with mode: 0644]

index fe849a333b9354523dd2086c218fbc48a757ecb8..420de5e6fb1a9ce37595795e5932796b629da76f 100644 (file)
@@ -1 +1,2 @@
 DIST wapiti3-3.0.2.tar.gz 561658 BLAKE2B f013b7d3c23cc3b655503de9f14d53b24d281604344c558791561c900fbe8b1a591c6b56970b41c961b38f65680799bf254887f4613d8e2bc96ddbc0a6aa7c24 SHA512 02f0e2510ce428b6dd89251ec63b5806b34e8e02302c7fa8fb1d9460a4e8c073b4650c066183ef20dc554440721f0b659a6ea30ad38f05865fb0fccc1cca758f
+DIST wapiti3-3.0.3.tar.gz 553259 BLAKE2B c31a1ce3e367c7b85141b0a83c9617a901f01753ebcc56142092d475bf3d540fac6d4e529fc87f5919c962303451787db9e1f8872a5e70a646ff48c1b076139e SHA512 ed135a97ee0c2431fa15d87888eca424db389e9e54b1426e0efe7a83299ee110cb9895916c5f5f3690a99f81034e8ad0d97e3e432b2d478b89a3ba14534ddb96
diff --git a/net-analyzer/wapiti/wapiti-3.0.3.ebuild b/net-analyzer/wapiti/wapiti-3.0.3.ebuild
new file mode 100644 (file)
index 0000000..a89de4e
--- /dev/null
@@ -0,0 +1,41 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7} )
+PYTHON_REQ_USE='xml'
+
+inherit distutils-r1
+
+MY_P=${PN}3-${PV}
+DESCRIPTION="Web-application vulnerability scanner"
+HOMEPAGE="http://wapiti.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="kerberos ntlm test"
+
+RESTRICT="!test? ( test )"
+
+DEPEND="test? (
+       dev-python/pytest[${PYTHON_USEDEP}]
+       dev-python/pytest-runner[${PYTHON_USEDEP}]
+       )"
+RDEPEND="dev-python/beautifulsoup:4[${PYTHON_USEDEP}]
+       dev-python/lxml[${PYTHON_USEDEP}]
+       dev-python/mako[${PYTHON_USEDEP}]
+       >=dev-python/requests-1.2.3[${PYTHON_USEDEP}]
+       dev-python/tld[${PYTHON_USEDEP}]
+       dev-python/yaswfp[${PYTHON_USEDEP}]
+       kerberos? ( dev-python/requests-kerberos[${PYTHON_USEDEP}] )
+       ntlm? ( dev-python/requests-ntlm[${PYTHON_USEDEP}] )"
+
+S=${WORKDIR}/${MY_P}
+
+python_prepare_all() {
+       sed -e 's/"pytest-runner"//' -i setup.py || die
+       distutils-r1_python_prepare_all
+}