dev-python/pytest-mock: Bump to version 1.11.2
authorZac Medico <zmedico@gentoo.org>
Sat, 26 Oct 2019 20:25:25 +0000 (13:25 -0700)
committerZac Medico <zmedico@gentoo.org>
Sat, 26 Oct 2019 20:33:31 +0000 (13:33 -0700)
Reported-by: Alessandro Barbieri <lssndrbarbieri@gmail.com>
Closes: https://bugs.gentoo.org/698554
Package-Manager: Portage-2.3.78, Repoman-2.3.17
Signed-off-by: Zac Medico <zmedico@gentoo.org>
dev-python/pytest-mock/Manifest
dev-python/pytest-mock/pytest-mock-1.11.2.ebuild [new file with mode: 0644]

index a6cc65b2e1aa94256938545876777e7ad4c06759..f9ac3ad34688f44038c237d8889ef90d64d2f3de 100644 (file)
@@ -1,3 +1,4 @@
 DIST pytest-mock-1.10.0.tar.gz 20754 BLAKE2B db60bfe6ee9d6d0a6ee4f0df7f5efa6ef05f5e2360945aa86ff6de02fc6a01f1e6715cbb61ced0c1e737c300965835fb08727b926852c5b71c0cc3d56c1171f1 SHA512 b8afba13da3e598b6493459298e395c0ecc06538733916659191bd5c5c22f40b0e296853ad940c16a6d492fcf46b2daf490ee589661d391e2c7cd1deb84da756
+DIST pytest-mock-1.11.2.tar.gz 22825 BLAKE2B d6843d1cb1afc0d5a242103ec4900d56418198b84fa037faf4b6841d7fbfd388273a819a26bfe051e6030690105e74211a27d2b864448598962b3e03788958fa SHA512 6dc927ce35001d088bddd9d79e024141b9e8163033b07af14b1f63330ef8b93dbf88649702f8fcc4f6ad314212fa5cbd39486b539811ec918450b3f7a716f96c
 DIST pytest-mock-1.6.0.tar.gz 17780 BLAKE2B 4fbc0cbd951668eb2ce427496c54e958591fe368bd42544eb1d0379adcb3d0e10b223ab044956e4003aac88665b3132dcb9d167442d6d85a5be79edea36881ca SHA512 c3b897be9156d57d7012e95b620c543500b849d7076224e3328d3783311210c57141dfb82c01bb98e5e419125dce0f68f6631bd610f4909f5ac1798458a7949f
 DIST pytest-mock-1.6.3.tar.gz 18482 BLAKE2B 1c0d366e5afd1b247ff454716b6d96d9d68846adfff81adc0ea079a72d3e7710fd9385122723cfee69965588235ec2deb1e0b52328ace5c967652c93b404cea3 SHA512 6857f373728d3f2c6b152d4f89da3590e2e74795695dc9f4f3704a4e0250e49d705ce0de4121a801ac35c83217678a95a5023338124293ca74db406941f5072a
diff --git a/dev-python/pytest-mock/pytest-mock-1.11.2.ebuild b/dev-python/pytest-mock/pytest-mock-1.11.2.ebuild
new file mode 100644 (file)
index 0000000..9abdcee
--- /dev/null
@@ -0,0 +1,39 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Thin-wrapper around the mock package for easier use with py.test"
+HOMEPAGE="https://github.com/pytest-dev/pytest-mock/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+RDEPEND="dev-python/pytest[${PYTHON_USEDEP}]
+       $(python_gen_cond_dep '>=dev-python/mock-2[${PYTHON_USEDEP}]' -2)"
+DEPEND="${RDEPEND}
+       dev-python/setuptools[${PYTHON_USEDEP}]
+       dev-python/setuptools_scm[${PYTHON_USEDEP}]"
+
+src_prepare() {
+       if has_version dev-python/mock; then
+               # test fails when standalone mock is installed
+               sed -e 's|^\(def \)\(test_standalone_mock(\)|\1_\2|' -i tests/test_pytest_mock.py || die
+       fi
+       sed -e 's|^\(    def \)\(test_failure_message_with_no_name(\)|\1_\2|' \
+               -e 's|^\(    def \)\(test_failure_message_with_name(\)|\1_\2|' \
+               -e 's|^\(def \)\(test_detailed_introspection(\)|\1_\2|' \
+               -i tests/test_pytest_mock.py || die
+       distutils-r1_src_prepare
+}
+
+python_test() {
+       local -x PYTHONPATH=${PWD}${PYTHONPATH:+:}${PYTHONPATH}
+       py.test -vv tests/test_pytest_mock.py || die "Tests fail with ${EPYTHON}"
+}