Version bumped, Bug 124120
authorMatsuu Takuto <matsuu@gentoo.org>
Tue, 6 Jun 2006 11:16:17 +0000 (11:16 +0000)
committerMatsuu Takuto <matsuu@gentoo.org>
Tue, 6 Jun 2006 11:16:17 +0000 (11:16 +0000)
Package-Manager: portage-2.1_rc4

media-sound/audacity/ChangeLog
media-sound/audacity/audacity-1.3.0b.ebuild [new file with mode: 0644]
media-sound/audacity/files/digest-audacity-1.2.4b-r1
media-sound/audacity/files/digest-audacity-1.3.0b [new file with mode: 0644]

index b75dbcee5ab878c53ccbdd5a9075421fa3b67779..639d384ce2f0f25eae5e902f2da4e122fab633a7 100644 (file)
@@ -1,6 +1,13 @@
 # ChangeLog for media-sound/audacity
 # Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/audacity/ChangeLog,v 1.41 2006/03/08 18:54:25 tove Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/audacity/ChangeLog,v 1.42 2006/06/06 11:16:17 matsuu Exp $
+
+*audacity-1.3.0b (06 Jun 2006)
+
+  06 Jun 2006; MATSUU Takuto <matsuu@gentoo.org> -audacity-1.2.2.ebuild,
+  -audacity-1.2.3-r1.ebuild, -audacity-1.2.4b.ebuild,
+  Version bumped, Bug 124120.
+  Removed old versions.
 
   27 Feb 2006; MATSUU Takuto <matsuu@gentoo.org> audacity-1.2.4b-r1.ebuild:
   Added epatch ${FILESDIR}/${PN}-1.2.3-x86.patch, Bug 121634.
diff --git a/media-sound/audacity/audacity-1.3.0b.ebuild b/media-sound/audacity/audacity-1.3.0b.ebuild
new file mode 100644 (file)
index 0000000..e75a801
--- /dev/null
@@ -0,0 +1,68 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/audacity/audacity-1.3.0b.ebuild,v 1.1 2006/06/06 11:16:17 matsuu Exp $
+
+inherit wxwidgets eutils
+
+IUSE="encode mad unicode"
+
+MY_P="${PN}-src-${PV}"
+DESCRIPTION="Free crossplatform audio editor"
+HOMEPAGE="http://audacity.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+
+DEPEND=">=x11-libs/wxGTK-2.6
+       >=app-arch/zip-2.3
+       media-libs/libid3tag
+       >=media-libs/libsndfile-1.0.0
+       >=media-libs/libvorbis-1.0
+       encode? ( >=media-sound/lame-3.92 )
+       mad? ( >=media-libs/libmad-0.14.2b )"
+
+WX_GTK_VER="2.6"
+
+S="${WORKDIR}/${MY_P}-beta"
+
+src_unpack() {
+       unpack ${A}
+
+       cd "${S}"
+       epatch "${FILESDIR}"/${PN}-1.2.3-gcc41.patch # bug 113754
+}
+
+src_compile() {
+       if built_with_use '>=x11-libs/wxGTK-2.6' unicode ; then
+               need-wxwidgets unicode
+       else
+               need-wxwidgets gtk2
+       fi
+
+       econf \
+               $(use_with mad libmad system) \
+               $(use_with flac system) \
+               --with-vorbis=system \
+               --with-id3tag=system \
+               --with-libsndfile=system || die
+
+       # parallel borks
+       emake -j1 || die
+}
+
+src_install() {
+       make DESTDIR="${D}" install || die
+
+       # Remove bad doc install
+       rm -rf ${D}/usr/share/doc
+
+       # Install our docs
+       dodoc README.txt audacity-1.2-help.htb
+
+       insinto /usr/share/icons/hicolor/48x48/apps
+       newins images/AudacityLogo48x48.xpm audacity.xpm
+
+       make_desktop_entry audacity Audacity audacity
+}
index 496c8a29c351d35dc08341e3b4b6fc49bea1ccca..ea0d798f8d94c0831af1c0dbb770a61c4c3ee0df 100644 (file)
@@ -1 +1,3 @@
 MD5 37df5b6119302f7ab77ca16d25311756 audacity-src-1.2.4b.tar.gz 4499894
+RMD160 4c6609b200a86ff081ecaa1789525404031563d6 audacity-src-1.2.4b.tar.gz 4499894
+SHA256 7c6f53ceffc10fbff96cc3fdf2a2b61072ed8b527d4f7313b3216390907de113 audacity-src-1.2.4b.tar.gz 4499894
diff --git a/media-sound/audacity/files/digest-audacity-1.3.0b b/media-sound/audacity/files/digest-audacity-1.3.0b
new file mode 100644 (file)
index 0000000..4cca069
--- /dev/null
@@ -0,0 +1,3 @@
+MD5 d1c5a3359ad95eab6ca8b375972c1a91 audacity-src-1.3.0b.tar.gz 4938302
+RMD160 4ada2e40799f60477d6c2aabb0b91bb03c8882f9 audacity-src-1.3.0b.tar.gz 4938302
+SHA256 cff02da856622acbca7b6ce9e0c05ad0cabc0c10fc5f79e349d2e586176e49f9 audacity-src-1.3.0b.tar.gz 4938302