dev-python/tzlocal: Bump to 2.0.0
authorMichał Górny <mgorny@gentoo.org>
Thu, 13 Feb 2020 17:10:14 +0000 (18:10 +0100)
committerMichał Górny <mgorny@gentoo.org>
Thu, 13 Feb 2020 17:11:53 +0000 (18:11 +0100)
Closes: https://bugs.gentoo.org/708328
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/tzlocal/Manifest
dev-python/tzlocal/tzlocal-2.0.0.ebuild [new file with mode: 0644]

index d71f4fcf572b1b15101b1c93d9c1ca3a16c6f4ad..2d7aa028f35bed8a78669fa454a6982f55a1c2e1 100644 (file)
@@ -1 +1,2 @@
 DIST tzlocal-1.2.tar.gz 16149 BLAKE2B 3852fdf9672bdb3f5b5340eaa14682f0f64bf3bad3e920680ce8ae7e12e3a2fb475237f6b645075e5058a30eff07c8ceec3ba4fa2bf90d4ea65663788cbcd772 SHA512 eb4d1f73983579e109249884d2a343c441942fb0d4dc76aed693c4a05100b10a2337d72794fdb9c0cd28c3b73e11dbd030bdf6dc2f75e57c958655219973c814
+DIST tzlocal-2.0.0.gh.tar.gz 18223 BLAKE2B 46c3132c60140ebe93a7bc0848f97d7ee7481f29544ba93d11bd6de3a6ff2d17c9e6643a844c2dc6236ef26baebec070bc60e829a95283b7c037624bdb1bda7f SHA512 b758f6ed9677e9aca3909a65f64c45ed21e8301d20ddd620be58312661c9e2a2305bed90e8b86afeae92e6be9e38a35385c8b76ccd7cb12b027c341585d7a6a6
diff --git a/dev-python/tzlocal/tzlocal-2.0.0.ebuild b/dev-python/tzlocal/tzlocal-2.0.0.ebuild
new file mode 100644 (file)
index 0000000..fcd01ca
--- /dev/null
@@ -0,0 +1,22 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit distutils-r1
+
+DESCRIPTION="tzinfo object for the local timezone"
+HOMEPAGE="https://github.com/regebro/tzlocal"
+SRC_URI="https://github.com/regebro/tzlocal/archive/${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE=""
+
+RDEPEND="dev-python/pytz[${PYTHON_USEDEP}]"
+DEPEND="test? ( dev-python/mock[${PYTHON_USEDEP}] )"
+
+distutils_enable_tests setup.py