dev-libs/openssl: bump to EAPI 7
authorThomas Deutschmann <whissi@gentoo.org>
Fri, 23 Aug 2019 17:31:22 +0000 (19:31 +0200)
committerThomas Deutschmann <whissi@gentoo.org>
Fri, 23 Aug 2019 18:10:17 +0000 (20:10 +0200)
Package-Manager: Portage-2.3.72, Repoman-2.3.17
Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
dev-libs/openssl/openssl-1.0.2s-r1.ebuild [moved from dev-libs/openssl/openssl-1.0.2s.ebuild with 92% similarity]
dev-libs/openssl/openssl-1.0.2s-r200.ebuild
dev-libs/openssl/openssl-1.1.0k-r1.ebuild [moved from dev-libs/openssl/openssl-1.1.0k.ebuild with 93% similarity]

similarity index 92%
rename from dev-libs/openssl/openssl-1.0.2s.ebuild
rename to dev-libs/openssl/openssl-1.0.2s-r1.ebuild
index 57280189ad1b543a1a3371fa31a83b045769b4e4..a2cb9f7917edca272968f29325118fc26b7fa998 100644 (file)
@@ -1,9 +1,9 @@
 # Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI="6"
+EAPI="7"
 
-inherit eutils flag-o-matic toolchain-funcs multilib multilib-minimal
+inherit flag-o-matic toolchain-funcs multilib multilib-minimal
 
 # openssl-1.0.2-patches-1.6 contain additional CVE patches
 # which got fixed with this release.
@@ -28,9 +28,10 @@ RESTRICT="!bindist? ( bindist )"
 
 RDEPEND=">=app-misc/c_rehash-1.7-r1
        gmp? ( >=dev-libs/gmp-5.1.3-r1[static-libs(+)?,${MULTILIB_USEDEP}] )
-       zlib? ( >=sys-libs/zlib-1.2.8-r1[static-libs(+)?,${MULTILIB_USEDEP}] )
-       kerberos? ( >=app-crypt/mit-krb5-1.11.4[${MULTILIB_USEDEP}] )"
-DEPEND="${RDEPEND}
+       kerberos? ( >=app-crypt/mit-krb5-1.11.4[${MULTILIB_USEDEP}] )
+       zlib? ( >=sys-libs/zlib-1.2.8-r1[static-libs(+)?,${MULTILIB_USEDEP}] )"
+DEPEND="${RDEPEND}"
+BDEPEND="
        >=dev-lang/perl-5
        sctp? ( >=net-misc/lksctp-tools-1.0.12 )
        test? (
@@ -95,7 +96,9 @@ src_prepare() {
        rm -f Makefile
 
        if ! use vanilla ; then
-               eapply "${WORKDIR}"/patch/*.patch
+               if [[ $(declare -p PATCHES 2>/dev/null) == "declare -a"* ]] ; then
+                       [[ ${#PATCHES[@]} -gt 0 ]] && eapply "${PATCHES[@]}"
+               fi
        fi
 
        eapply_user
@@ -109,7 +112,7 @@ src_prepare() {
                -e '/^MAKEDEPPROG/s:=.*:=$(CC):' \
                -e $(has noman FEATURES \
                        && echo '/^install:/s:install_docs::' \
-                       || echo '/^MANDIR=/s:=.*:='${EPREFIX%/}'/usr/share/man:') \
+                       || echo '/^MANDIR=/s:=.*:='${EPREFIX}'/usr/share/man:') \
                Makefile.org \
                || die
        # show the actual commands in the log
@@ -134,7 +137,7 @@ src_prepare() {
        append-flags $(test-flags-CC -Wa,--noexecstack)
        append-cppflags -DOPENSSL_NO_BUF_FREELISTS
 
-       sed -i '1s,^:$,#!'${EPREFIX%/}'/usr/bin/perl,' Configure #141906
+       sed -i '1s,^:$,#!'${EPREFIX}'/usr/bin/perl,' Configure #141906
        # The config script does stupid stuff to prompt the user.  Kill it.
        sed -i '/stty -icanon min 0 time 50; read waste/d' config || die
        ./config --test-sanity || die "I AM NOT SANE"
@@ -206,8 +209,8 @@ multilib_src_configure() {
                $(use_ssl sslv3 ssl3) \
                $(use_ssl tls-heartbeat heartbeats) \
                $(use_ssl zlib) \
-               --prefix="${EPREFIX%/}"/usr \
-               --openssldir="${EPREFIX%/}"${SSL_CNF_DIR} \
+               --prefix="${EPREFIX}"/usr \
+               --openssldir="${EPREFIX}"${SSL_CNF_DIR} \
                --libdir=$(get_libdir) \
                shared threads \
                || die
@@ -243,18 +246,18 @@ multilib_src_test() {
 
 multilib_src_install() {
        # We need to create $ED/usr on our own to avoid a race condition #665130
-       if [[ ! -d "${ED%/}/usr" ]]; then
+       if [[ ! -d "${ED}/usr" ]]; then
                # We can only create this directory once
-               mkdir "${ED%/}"/usr || die
+               mkdir "${ED}"/usr || die
        fi
 
-       emake INSTALL_PREFIX="${D%/}" install
+       emake INSTALL_PREFIX="${D}" install
 }
 
 multilib_src_install_all() {
        # openssl installs perl version of c_rehash by default, but
        # we provide a shell version via app-misc/c_rehash
-       rm "${ED%/}"/usr/bin/c_rehash || die
+       rm "${ED}"/usr/bin/c_rehash || die
 
        local -a DOCS=( CHANGES* FAQ NEWS README doc/*.txt doc/c-indentation.el )
        einstalldocs
@@ -303,7 +306,7 @@ multilib_src_install_all() {
 }
 
 pkg_postinst() {
-       ebegin "Running 'c_rehash ${EROOT%/}${SSL_CNF_DIR}/certs/' to rebuild hashes #333069"
-       c_rehash "${EROOT%/}${SSL_CNF_DIR}/certs" >/dev/null
+       ebegin "Running 'c_rehash ${EROOT}${SSL_CNF_DIR}/certs/' to rebuild hashes #333069"
+       c_rehash "${EROOT}${SSL_CNF_DIR}/certs" >/dev/null
        eend $?
 }
index 44b9547d141ea4bf8628d8ec62a3e39e6ddb585a..281b169b64b09eb3bf343c136ee99f0e61be44a5 100644 (file)
@@ -1,9 +1,9 @@
 # Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI="6"
+EAPI="7"
 
-inherit eutils flag-o-matic toolchain-funcs multilib multilib-minimal
+inherit flag-o-matic toolchain-funcs multilib multilib-minimal
 
 # openssl-1.0.2-patches-1.6 contain additional CVE patches
 # which got fixed with this release.
@@ -22,16 +22,16 @@ SRC_URI="mirror://openssl/source/${MY_P}.tar.gz
 
 LICENSE="openssl"
 SLOT="1.0.0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-linux"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-linux"
 IUSE="+asm bindist gmp kerberos rfc3779 sctp cpu_flags_x86_sse2 sslv2 +sslv3 static-libs test +tls-heartbeat vanilla zlib"
 RESTRICT="!bindist? ( bindist )"
 
-RDEPEND=">=app-misc/c_rehash-1.7-r1
-       gmp? ( >=dev-libs/gmp-5.1.3-r1[static-libs(+)?,${MULTILIB_USEDEP}] )
-       zlib? ( >=sys-libs/zlib-1.2.8-r1[static-libs(+)?,${MULTILIB_USEDEP}] )
+RDEPEND="gmp? ( >=dev-libs/gmp-5.1.3-r1[static-libs(+)?,${MULTILIB_USEDEP}] )
        kerberos? ( >=app-crypt/mit-krb5-1.11.4[${MULTILIB_USEDEP}] )
+       zlib? ( >=sys-libs/zlib-1.2.8-r1[static-libs(+)?,${MULTILIB_USEDEP}] )
        !=dev-libs/openssl-1.0.2*:0"
-DEPEND="${RDEPEND}
+DEPEND="${RDEPEND}"
+BDEPEND="
        >=dev-lang/perl-5
        sctp? ( >=net-misc/lksctp-tools-1.0.12 )
        test? (
@@ -100,7 +100,9 @@ src_prepare() {
        rm -f Makefile
 
        if ! use vanilla ; then
-               eapply "${WORKDIR}"/patch/*.patch
+               if [[ $(declare -p PATCHES 2>/dev/null) == "declare -a"* ]] ; then
+                       [[ ${#PATCHES[@]} -gt 0 ]] && eapply "${PATCHES[@]}"
+               fi
        fi
 
        eapply_user
@@ -114,7 +116,7 @@ src_prepare() {
                -e '/^MAKEDEPPROG/s:=.*:=$(CC):' \
                -e $(has noman FEATURES \
                        && echo '/^install:/s:install_docs::' \
-                       || echo '/^MANDIR=/s:=.*:='${EPREFIX%/}'/usr/share/man:') \
+                       || echo '/^MANDIR=/s:=.*:='${EPREFIX}'/usr/share/man:') \
                Makefile.org \
                || die
        # show the actual commands in the log
@@ -139,7 +141,7 @@ src_prepare() {
        append-flags $(test-flags-CC -Wa,--noexecstack)
        append-cppflags -DOPENSSL_NO_BUF_FREELISTS
 
-       sed -i '1s,^:$,#!'${EPREFIX%/}'/usr/bin/perl,' Configure #141906
+       sed -i '1s,^:$,#!'${EPREFIX}'/usr/bin/perl,' Configure #141906
        # The config script does stupid stuff to prompt the user.  Kill it.
        sed -i '/stty -icanon min 0 time 50; read waste/d' config || die
        ./config --test-sanity || die "I AM NOT SANE"
@@ -211,8 +213,8 @@ multilib_src_configure() {
                $(use_ssl sslv3 ssl3) \
                $(use_ssl tls-heartbeat heartbeats) \
                $(use_ssl zlib) \
-               --prefix="${EPREFIX%/}"/usr \
-               --openssldir="${EPREFIX%/}"${SSL_CNF_DIR} \
+               --prefix="${EPREFIX}"/usr \
+               --openssldir="${EPREFIX}"${SSL_CNF_DIR} \
                --libdir=$(get_libdir) \
                shared threads \
                || die
similarity index 93%
rename from dev-libs/openssl/openssl-1.1.0k.ebuild
rename to dev-libs/openssl/openssl-1.1.0k-r1.ebuild
index f5af55a9879c9f65c5c8acf9bc5d940ed9228e7e..5bc111be0f81a18314c30ee58fe7014d0959555d 100644 (file)
@@ -1,7 +1,7 @@
 # Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI="6"
+EAPI="7"
 
 inherit flag-o-matic toolchain-funcs multilib multilib-minimal
 
@@ -18,7 +18,8 @@ RESTRICT="!bindist? ( bindist )"
 
 RDEPEND=">=app-misc/c_rehash-1.7-r1
        zlib? ( >=sys-libs/zlib-1.2.8-r1[static-libs(+)?,${MULTILIB_USEDEP}] )"
-DEPEND="${RDEPEND}
+DEPEND="${RDEPEND}"
+BDEPEND="
        >=dev-lang/perl-5
        sctp? ( >=net-misc/lksctp-tools-1.0.12 )
        test? (
@@ -49,17 +50,17 @@ for i in "${FEDORA_PATCH[@]}" ; do # Already have a version prefix
 done
 SRC_URI+=" bindist? ( ${FEDORA_SRC_URI[@]} )"
 
+PATCHES=(
+       "${FILESDIR}"/${PN}-1.0.2a-x32-asm.patch #542618
+       "${FILESDIR}"/${PN}-1.1.0j-parallel_install_fix.patch #671602
+)
+
 S="${WORKDIR}/${MY_P}"
 
 MULTILIB_WRAPPED_HEADERS=(
        usr/include/openssl/opensslconf.h
 )
 
-PATCHES=(
-       "${FILESDIR}"/${PN}-1.0.2a-x32-asm.patch #542618
-       "${FILESDIR}"/${PN}-1.1.0j-parallel_install_fix.patch #671602
-)
-
 src_prepare() {
        if use bindist; then
                # we need to patch the patch but we cannot patch in DISTDIR...
@@ -98,7 +99,9 @@ src_prepare() {
        rm -f Makefile
 
        if ! use vanilla ; then
-               eapply "${PATCHES[@]}"
+               if [[ $(declare -p PATCHES 2>/dev/null) == "declare -a"* ]] ; then
+                       [[ ${#PATCHES[@]} -gt 0 ]] && eapply "${PATCHES[@]}"
+               fi
        fi
 
        eapply_user #332661
@@ -241,13 +244,19 @@ multilib_src_test() {
 }
 
 multilib_src_install() {
+       # We need to create $ED/usr on our own to avoid a race condition #665130
+       if [[ ! -d "${ED}/usr" ]]; then
+               # We can only create this directory once
+               mkdir "${ED}"/usr || die
+       fi
+
        emake DESTDIR="${D}" install
 }
 
 multilib_src_install_all() {
        # openssl installs perl version of c_rehash by default, but
        # we provide a shell version via app-misc/c_rehash
-       rm "${ED%/}"/usr/bin/c_rehash || die
+       rm "${ED}"/usr/bin/c_rehash || die
 
        dodoc CHANGES* FAQ NEWS README doc/*.txt doc/${PN}-c-indent.el
 
@@ -256,13 +265,13 @@ multilib_src_install_all() {
        # build system: the static archives are built as PIC all the time.
        # Only way around this would be to manually configure+compile openssl
        # twice; once with shared lib support enabled and once without.
-       use static-libs || rm -f "${ED%/}"/usr/lib*/lib*.a
+       use static-libs || rm -f "${ED}"/usr/lib*/lib*.a
 
        # create the certs directory
        keepdir ${SSL_CNF_DIR}/certs
 
        # Namespace openssl programs to prevent conflicts with other man pages
-       cd "${ED%/}"/usr/share/man || die
+       cd "${ED}"/usr/share/man || die
        local m d s
        for m in $(find . -type f | xargs grep -L '#include') ; do
                d=${m%/*} ; d=${d#./} ; m=${m##*/}
@@ -285,14 +294,14 @@ multilib_src_install_all() {
        [[ -n $(find -L ${d} -type l) ]] && die "broken manpage links found :("
 
        dodir /etc/sandbox.d #254521
-       echo 'SANDBOX_PREDICT="/dev/crypto"' > "${ED%/}"/etc/sandbox.d/10openssl
+       echo 'SANDBOX_PREDICT="/dev/crypto"' > "${ED}"/etc/sandbox.d/10openssl
 
        diropts -m0700
        keepdir ${SSL_CNF_DIR}/private
 }
 
 pkg_postinst() {
-       ebegin "Running 'c_rehash ${EROOT%/}${SSL_CNF_DIR}/certs/' to rebuild hashes #333069"
-       c_rehash "${EROOT%/}${SSL_CNF_DIR}/certs" >/dev/null
+       ebegin "Running 'c_rehash ${EROOT}${SSL_CNF_DIR}/certs/' to rebuild hashes #333069"
+       c_rehash "${EROOT}${SSL_CNF_DIR}/certs" >/dev/null
        eend $?
 }