dev-ruby/activesupport: remove rails 4.2
authorHans de Graaff <graaff@gentoo.org>
Tue, 5 May 2020 08:04:33 +0000 (10:04 +0200)
committerHans de Graaff <graaff@gentoo.org>
Tue, 5 May 2020 08:05:52 +0000 (10:05 +0200)
Package-Manager: Portage-2.3.99, Repoman-2.3.20
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
dev-ruby/activesupport/Manifest
dev-ruby/activesupport/activesupport-4.2.11.1.ebuild [deleted file]

index 59a1700d6da7a7f41def4277a9c8037854be1bd3..cade3ca76a82e5d673c9e405f5a7a04d5f5594f7 100644 (file)
@@ -1,3 +1,2 @@
-DIST rails-4.2.11.1.tgz 4081006 BLAKE2B 7db84961963f529a9b6c06011bb6e32b56f4beb064de31c811a092d27e93156669ade4dcceb7d8abcdba4845d42258d904f8ecaf79198af1c0e2afcb33fe3fe3 SHA512 198fa072f3f09a9893377439ddd1803effdf04a33ae7b609234464e7de9ad960439d1b80ae62e1f9b223b3173839be7233c314a72057933b43672f390d96a8df
 DIST rails-5.2.4.2.tgz 8823143 BLAKE2B 273bee6ccc2354bcfd8d24b320fe69c24f643c196eba053c727d30b13d4178069068c430a0a4112ae28c3e4b5a5dde0b66a7c46c7c28054f2b7a678427f478af SHA512 21561407a0b606dbd2fb6ad12ef910c0bdf3d5162db7e55f4f41f698280ba73664b0b5594930d4cebcb42a66e2e5e22de3523789818eb424443e8c5b2316b8fc
 DIST rails-6.0.2.2.tgz 18556125 BLAKE2B f4ed5cc6cbbfa84fb687aba5a6c8f2f6ab68febb41147c40ed8dbc6253c128adbac6503e65e89fe672f50270716d197d8c05b4e1e286aafd76581fc167e6c5da SHA512 c1aab2d6c72948c75a047aec9d9f651f0c1bae78bb17e2fa0cb393113ee1e59980dc093e6f3fd3b2f3839c9b3bb4afcd0b0badfd9574b35b932275a9d9800689
diff --git a/dev-ruby/activesupport/activesupport-4.2.11.1.ebuild b/dev-ruby/activesupport/activesupport-4.2.11.1.ebuild
deleted file mode 100644 (file)
index 4424d71..0000000
+++ /dev/null
@@ -1,66 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-USE_RUBY="ruby23 ruby24"
-
-RUBY_FAKEGEM_TASK_DOC=""
-
-RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.rdoc"
-
-RUBY_FAKEGEM_GEMSPEC="activesupport.gemspec"
-
-RUBY_FAKEGEM_BINWRAP=""
-
-inherit ruby-fakegem versionator
-
-DESCRIPTION="Utility Classes and Extension to the Standard Library"
-HOMEPAGE="https://github.com/rails/rails"
-SRC_URI="https://github.com/rails/rails/archive/v${PV}.tar.gz -> rails-${PV}.tgz"
-
-LICENSE="MIT"
-SLOT="$(get_version_component_range 1-2)"
-KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~x86 ~amd64-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE=""
-
-RUBY_S="rails-${PV}/${PN}"
-
-ruby_add_rdepend "
-       >=dev-ruby/i18n-0.7:0.7
-       >=dev-ruby/tzinfo-1.1:1
-       >=dev-ruby/minitest-5.1:5
-       >=dev-ruby/thread_safe-0.3.4:0"
-
-# memcache-client, nokogiri, and builder are not strictly
-# needed, but there are tests using this code.
-ruby_add_bdepend "test? (
-       >=dev-ruby/dalli-2.2.1
-       >=dev-ruby/nokogiri-1.4.5
-       >=dev-ruby/builder-3.1.0
-       dev-ruby/rack
-       dev-ruby/mocha:0.14
-       )"
-
-all_ruby_prepare() {
-       # Set the secure permissions that tests expect.
-       chmod 0755 "${HOME}" || die "Failed to fix permissions on home"
-
-       # Remove items from the common Gemfile that we don't need for this
-       # test run. This also requires handling some gemspecs.
-       sed -i -e "/\(system_timer\|sdoc\|w3c_validators\|pg\|execjs\|jquery-rails\|mysql\|journey\|ruby-prof\|stackprof\|benchmark-ips\|kindlerb\|turbolinks\|coffee-rails\|debugger\|sprockets-rails\|redcarpet\|bcrypt\|uglifier\|minitest\|mime-types\|sprockets\|stackprof\|rack-cache\|sqlite\)/ s:^:#:" \
-               -e '/:job/,/end/ s:^:#:' \
-               -e '/group :doc/,/^end/ s:^:#:' \
-               -e 's/gemspec/gemspec path: "activesupport"/' \
-               -e '/rake/ s/12.3/12.4/ ; /dalli/ s/2.7.7/2.7.10/' \
-               -e '5igem "builder"; gem "rack"' ../Gemfile || die
-       rm ../Gemfile.lock || die
-
-       # Avoid test that fails with Minitest 5.4 since that already defines
-       # a string E in its TestCase.
-       rm test/core_ext/marshal_test.rb || die
-       sed -i -e '/test_const_missing_in_anonymous_modules/askip "gentoo minitest"' test/dependencies_test.rb || die
-
-       # Avoid test crashing newer versions of minitest
-       rm -f test/autoload_test.rb test/core_ext/object/json_cherry_pick_test.rb test/core_ext/object/json_gem_encoding_test.rb || die
-}