dev-python/errorhandler: bump to 2.0.1
authorVirgil Dupras <vdupras@gentoo.org>
Wed, 8 May 2019 14:08:42 +0000 (10:08 -0400)
committerVirgil Dupras <vdupras@gentoo.org>
Wed, 8 May 2019 14:41:16 +0000 (10:41 -0400)
Signed-off-by: Virgil Dupras <vdupras@gentoo.org>
Package-Manager: Portage-2.3.62, Repoman-2.3.11

dev-python/errorhandler/Manifest
dev-python/errorhandler/errorhandler-2.0.1.ebuild [new file with mode: 0644]
dev-python/errorhandler/files/errorhandler-2.0.1-no-intersphinx.patch [new file with mode: 0644]

index 54112c0ccfaaf56f8d56bd5d3cf58caa074a6021..11918a6331fc4d466c9d781566aca032eb8b0f1b 100644 (file)
@@ -1 +1,2 @@
 DIST errorhandler-1.1.1.tar.gz 8321 BLAKE2B f2b0cc9dcf9bf86c1b89356f66fca2d64d49acb919ae6bfc18b1dcb013cb67a358f2f81d47cd1c3bca601c85fc3bb5f870e1cc2452d25b187309a844efed15b3 SHA512 a2f875537103086be956becfdac25a43a646a89b404b6a7a2a243c6d2ddbc29d55948b781529d0a0fa82b163187747f3396b62ed0be98d39834de038cc4a1fd2
+DIST errorhandler-2.0.1.tar.gz 8534 BLAKE2B 2a1db016acef81b5e625800614b2b5084cb6e8175d623e42726a728018871d200709ec66db16847ae0cf604551925a18fd2207c861388844f324a6eaae4bbe90 SHA512 b2fe44f400551e2af8aa589aefce042ee761893678b211a0e3ec7eb4527803001ac930d0941425f6e1487d36493d0c8f439e0bf672536ec27f041309fd69420e
diff --git a/dev-python/errorhandler/errorhandler-2.0.1.ebuild b/dev-python/errorhandler/errorhandler-2.0.1.ebuild
new file mode 100644 (file)
index 0000000..042a4d7
--- /dev/null
@@ -0,0 +1,42 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Logging framework handler"
+HOMEPAGE="https://pypi.org/project/errorhandler/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+
+LICENSE="MIT"
+SLOT="0"
+
+RDEPEND=""
+DEPEND="
+       dev-python/pkginfo[${PYTHON_USEDEP}]
+       dev-python/setuptools[${PYTHON_USEDEP}]
+       doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+       test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+
+PATCHES=(
+       "${FILESDIR}"/${PN}-2.0.1-no-intersphinx.patch
+)
+
+python_compile_all() {
+       use doc && emake -C docs html
+}
+
+python_test() {
+       nosetests -v || die "Tests fail with ${EPYTHON}"
+}
+
+python_install_all() {
+       use doc && local HTML_DOCS=( docs/_build/html/. )
+       distutils-r1_python_install_all
+}
diff --git a/dev-python/errorhandler/files/errorhandler-2.0.1-no-intersphinx.patch b/dev-python/errorhandler/files/errorhandler-2.0.1-no-intersphinx.patch
new file mode 100644 (file)
index 0000000..d37e190
--- /dev/null
@@ -0,0 +1,12 @@
+diff --git a/docs/conf.py b/docs/conf.py
+index 2c71c44..0e6f0ae 100644
+--- a/docs/conf.py
++++ b/docs/conf.py
+@@ -5,7 +5,6 @@ pkg_info = pkginfo.Develop(os.path.join(os.path.dirname(__file__),'..'))
+ extensions = [
+     'sphinx.ext.autodoc',
+-    'sphinx.ext.intersphinx'
+     ]
+ intersphinx_mapping = {'http://docs.python.org/dev': None}