dev-haskell/shellish: tweak for ghc-7.10, bug #561028
authorSergei Trofimovich <slyfox@gentoo.org>
Mon, 21 Sep 2015 19:51:23 +0000 (20:51 +0100)
committerSergei Trofimovich <slyfox@gentoo.org>
Mon, 21 Sep 2015 19:52:02 +0000 (20:52 +0100)
Reported-by: Toralf Förster
Bug: https://bugs.gentoo.org/561028

Package-Manager: portage-2.2.20

dev-haskell/shellish/files/shellish-0.1.4-ghc-7.10.patch [new file with mode: 0644]
dev-haskell/shellish/shellish-0.1.4.ebuild

diff --git a/dev-haskell/shellish/files/shellish-0.1.4-ghc-7.10.patch b/dev-haskell/shellish/files/shellish-0.1.4-ghc-7.10.patch
new file mode 100644 (file)
index 0000000..c756635
--- /dev/null
@@ -0,0 +1,9 @@
+diff --git a/Shellish.hs b/Shellish.hs
+index 1e3c192..0ac20c2 100644
+--- a/Shellish.hs
++++ b/Shellish.hs
+@@ -1,3 +1,3 @@
+ {-# LANGUAGE ScopedTypeVariables, DeriveDataTypeable, OverloadedStrings,
+-             MultiParamTypeClasses, FlexibleInstances #-}
++             MultiParamTypeClasses, FlexibleInstances, FlexibleContexts #-}
index 86f421a07c2b19c8b5db3dec6d102b936d0da211..f93d8797cc7ac228f03d79cfee850fbcec355a2c 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 # $Id$
 
@@ -24,3 +24,7 @@ RDEPEND="dev-haskell/mtl[profile?]
                >=dev-lang/ghc-6.10.1"
 DEPEND="${RDEPEND}
                >=dev-haskell/cabal-1.6"
+
+src_prepare() {
+       epatch "${FILESDIR}"/${P}-ghc-7.10.patch
+}