x11-plugins/wmfsm: restore stable ebuild, bug #558860
authorBernard Cafarelli <voyageur@gentoo.org>
Thu, 27 Aug 2015 08:03:43 +0000 (10:03 +0200)
committerBernard Cafarelli <voyageur@gentoo.org>
Thu, 27 Aug 2015 08:18:28 +0000 (10:18 +0200)
This partially reverts commit a9a09346

x11-plugins/wmfsm/wmfsm-0.34-r1.ebuild [new file with mode: 0644]

diff --git a/x11-plugins/wmfsm/wmfsm-0.34-r1.ebuild b/x11-plugins/wmfsm/wmfsm-0.34-r1.ebuild
new file mode 100644 (file)
index 0000000..92b62b9
--- /dev/null
@@ -0,0 +1,33 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils
+
+IUSE=""
+DESCRIPTION="dockapp for monitoring filesystem usage"
+HOMEPAGE="http://dockapps.windowmaker.org/file.php/id/100"
+SRC_URI="mirror://gentoo/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc sparc x86"
+
+RDEPEND="x11-libs/libX11
+       x11-libs/libXext
+       x11-libs/libXt
+       x11-libs/libXpm"
+DEPEND="${RDEPEND}
+       x11-proto/xproto
+       x11-proto/xextproto"
+
+src_unpack() {
+       unpack ${A}
+       cd "${S}"/wmfsm
+       epatch "${FILESDIR}"/${P}.linux-fs.patch
+}
+
+src_install() {
+       emake DESTDIR="${D}" install || die "make install failed"
+       dodoc AUTHORS ChangeLog
+}