app-admin/terraform: Bump version to 0.12.3
authorDan Molik <dan@danmolik.com>
Fri, 28 Jun 2019 16:46:40 +0000 (12:46 -0400)
committerMichał Górny <mgorny@gentoo.org>
Fri, 5 Jul 2019 19:33:44 +0000 (21:33 +0200)
Package-Manager: Portage-2.3.67, Repoman-2.3.15
Signed-off-by: Dan Molik <dan@danmolik.com>
Tested-by: Dan Molik <dan@danmolik.com>
Signed-off-by: Michał Górny <mgorny@gentoo.org>
app-admin/terraform/Manifest
app-admin/terraform/terraform-0.12.3.ebuild [new file with mode: 0644]

index 26c3674d61bfe5bd75706cbf0fb23e5d2aa37d45..8a72f8e1fb60d6463e6299e833f7cb5c0bf18ea6 100644 (file)
@@ -1,2 +1,3 @@
 DIST terraform-0.11.12.tar.gz 10907800 BLAKE2B d6d3c0a25b994be9b61e250a35adae55ed6cea0cc2166ea62774940292d9e881f16b66b88b19d5fd2c64d19bdefb82b58c79c54d8c641e1ad2970ef9a463c4c8 SHA512 2163cbc13a2bd37b7dace0a4ee2b3da4ee212038f9d6e11b83e509a794cf8d854040c366a099c9560a149157c6951b1f9d1698b4c47bd11a4fa96c4521e93414
 DIST terraform-0.11.13.tar.gz 10906645 BLAKE2B dafdc1acddd4ea97b41cc5899a541701731fce7b13b914c0859fe148b10b5c8ac877d71b665e8d80a65f376bb09fb8ae6fd0e0263ff711a156ca48119522f89d SHA512 1c16f20d1a65c763f1091ff2d20e0752e62903e07a12d41dd722e5c4c989f477da7d64901336d7536ed1693d5c82f4548ae5a643edae85b4e83325fc8c81b245
+DIST terraform-0.12.3.tar.gz 9702723 BLAKE2B 90a6c77d1e1d6cac761572a470e23d44705fd0326ea9e2b280f51d9c95c85a74951ed93d8d8eed56821209bbd0725ffc034cf19bbb2da2baa390eafac790ac76 SHA512 49e1fefbfaf0dc0b0505836133c95dd5b664babfbdec094288ac823678cfb6e1593b19c9a0dca608cb1c7063f1ad531adba470c5ec67e3d245ef1e4341fd5b4a
diff --git a/app-admin/terraform/terraform-0.12.3.ebuild b/app-admin/terraform/terraform-0.12.3.ebuild
new file mode 100644 (file)
index 0000000..da8687c
--- /dev/null
@@ -0,0 +1,37 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit golang-vcs-snapshot
+
+DESCRIPTION="A tool for building, changing, and combining infrastructure safely"
+HOMEPAGE="https://www.terraform.io/"
+
+EGO_PN="github.com/hashicorp/${PN}"
+SRC_URI="https://github.com/hashicorp/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+DEPEND=">=dev-lang/go-1.11.0"
+
+DOCS=( src/${EGO_PN}/{README,CHANGELOG}.md )
+
+src_compile() {
+       cd "src/${EGO_PN}" || die
+       GOPATH="${S}" GOCACHE="${T}/go-cache" go build \
+               -v -work -o "${S}/${PN}" ./ || die
+}
+
+src_install() {
+       dobin terraform
+
+       einstalldocs
+}
+
+pkg_postinst() {
+       elog "If you would like to install shell completions please run:"
+       elog "    terraform -install-autocomplete"
+}