dev-python/rpy: Resolve circular dependency
authorJustin Lecher <jlec@gentoo.org>
Tue, 1 Sep 2015 14:08:11 +0000 (16:08 +0200)
committerJustin Lecher <jlec@gentoo.org>
Wed, 2 Sep 2015 07:20:57 +0000 (09:20 +0200)
Package-Manager: portage-2.2.20.1
Signed-off-by: Justin Lecher <jlec@gentoo.org>
dev-python/rpy/rpy-2.6.2.ebuild

index 521031d20b63ef7d8e315d47b3d638fc0efcba6c..c2ae3efa01157423c75b2a9c3d412962475a04fd 100644 (file)
@@ -26,12 +26,12 @@ RDEPEND="
        >=dev-lang/R-3.1
        dev-python/numpy[${PYTHON_USEDEP}]
        >=dev-python/pandas-0.13.1[${PYTHON_USEDEP}]
-       dev-python/ipython[${PYTHON_USEDEP}]
        virtual/python-singledispatch[${PYTHON_USEDEP}]
        dev-python/six[${PYTHON_USEDEP}]"
 DEPEND="${RDEPEND}
        dev-python/setuptools[${PYTHON_USEDEP}]
        test? ( $(python_gen_cond_dep 'dev-python/singledispatch[${PYTHON_USEDEP}]' python2_7 python3_3) )"
+PDEPEND="dev-python/ipython[${PYTHON_USEDEP}]"
 
 # ggplot2 is an optional test dep but not in portage
 S="${WORKDIR}/${MY_P}"