dev-python/sphinx: Disable intersphinx
authorMichał Górny <mgorny@gentoo.org>
Thu, 7 May 2020 07:55:02 +0000 (09:55 +0200)
committerMichał Górny <mgorny@gentoo.org>
Thu, 7 May 2020 08:56:51 +0000 (10:56 +0200)
Closes: https://bugs.gentoo.org/721306
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/sphinx/sphinx-3.0.3.ebuild

index ea19d76fea3f3962607daeee6fdeeb4b15e1be02..3154c9ce95ac052de73caf0034e0765515d0b8bf 100644 (file)
@@ -86,6 +86,10 @@ python_prepare_all() {
 @pytest.mark.skipif(hasattr(sys, "pypy_version_info"), reason="broken on pypy3")' \
                tests/test_pycode_parser.py || die
 
+       # disable internet access
+       sed -i -e 's:^intersphinx_mapping:disabled_&:' \
+               doc/conf.py || die
+
        distutils-r1_python_prepare_all
 }