dev-libs/serdisplib: bump to version 2.02
authorConrad Kostecki <conikost@gentoo.org>
Thu, 5 Dec 2019 20:37:55 +0000 (21:37 +0100)
committerConrad Kostecki <conikost@gentoo.org>
Thu, 5 Dec 2019 21:46:06 +0000 (22:46 +0100)
Package-Manager: Portage-2.3.80, Repoman-2.3.19
Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
dev-libs/serdisplib/Manifest
dev-libs/serdisplib/serdisplib-2.02.ebuild [new file with mode: 0644]

index 569cc795a7486531762fdad66a27cbb4f9bb4d72..5e37876766d5f3891d451513445a7f9dc6e4915f 100644 (file)
@@ -1,2 +1,3 @@
 DIST serdisplib-1.97.9.tar.gz 293190 BLAKE2B f11406acaedb724d51266510d10f5cbae7e3bf1a69e3378ed8a0f8c4551336e3d662eb104ccc938f72821aec3406e1eed27754c990e17940d8dbe7dd8c5d6805 SHA512 ab45202fd1fd85b12f1ebf7a7e1a4575ad363f6faffd45949300840456e26dd521c70b67ff57c32e1ff6c0a9f2668b3be6a653afb57ba6da701fbae6e8db3118
 DIST serdisplib-2.01.tar.gz 472998 BLAKE2B 7ee78703d1d2cb4172e44db443825dd0fb3080284e832c60a102b853a1df6e0812a30a40504b8eb3e5ecda83f57138d78b43c3c40b8e4efabb7071eff7ad1b3e SHA512 0474cce4353edb3640d8432272905859e90efe6140e6791c84e1cb51df7f533734a9c78447d8d8448a70e62dda6d65061bbcc515ee346354825029874ae5e9a9
+DIST serdisplib-2.02.tar.gz 497028 BLAKE2B f35b6df60303a288b2a279d821a510089802019f33b7ee36b9c2fd1d1d6bef0b3118793e6d965076c1665e1e2555a553186ef1a9210712ef9d2bc1e090ec0a98 SHA512 d9936c25dc14e24eb02876f203476752340e621d8ee5c87ee99862575e45199bf46ff8487dfdd80b16a89543958fdf5a16a2aaf78d5cade06811cfb1592c45eb
diff --git a/dev-libs/serdisplib/serdisplib-2.02.ebuild b/dev-libs/serdisplib/serdisplib-2.02.ebuild
new file mode 100644 (file)
index 0000000..3014edb
--- /dev/null
@@ -0,0 +1,100 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit udev
+
+DESCRIPTION="Library to drive several displays with built-in controllers or display modules"
+HOMEPAGE="http://serdisplib.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="threads tools"
+
+# Define the list of valid lcd devices.
+IUSE_LCD_DEVICES=(
+       acoolsdcm ddusbt directgfx displaylink framebuffer glcd2usb
+       goldelox i2c ks0108 l4m lc7981 lh155 nokcol pcd8544
+       remote rs232 sed133x sed153x sed156x ssdoled stv8105 t6963
+)
+
+# Add supported drivers from 'IUSE_LCD_DEVICES' to 'IUSE' and 'REQUIRED_USE'
+IUSE+=" $(printf 'lcd_devices_%s ' ${IUSE_LCD_DEVICES[@]}) "
+REQUIRED_USE+="
+       || ( $(printf 'lcd_devices_%s ' ${IUSE_LCD_DEVICES[@]}) )
+       lcd_devices_framebuffer? ( threads )
+"
+
+# Specific drivers will need some features to be enabled
+RDEPEND="
+       media-libs/gd[jpeg,png,tiff]
+       lcd_devices_acoolsdcm? ( virtual/libusb:1 )
+       lcd_devices_directgfx? ( media-libs/libsdl )
+       lcd_devices_displaylink? ( x11-libs/libdlo )
+       lcd_devices_glcd2usb? ( virtual/libusb:1 )
+"
+
+DEPEND="${RDEPEND}"
+
+DOCS=( "AUTHORS" "BUGS" "DOCS" "HISTORY" "PINOUTS" "README" "TODO" )
+
+PATCHES=( "${FILESDIR}/use-destdir.patch" "${FILESDIR}/disable-static-build.patch" )
+
+src_prepare() {
+       default
+
+       # Fix Makefile, as it will fail, when USE="tools" is not set
+       if ! use tools; then
+               sed -i -e '/$(INSTALL_PROGRAM) $(PROGRAMS)/d' src/Makefile.in || die
+       fi
+
+       # Fix QA-Warning "QA Notice: pkg-config files with wrong LDFLAGS detected"
+       sed -i -e '/@LDFLAGS@/d' serdisplib.pc.in || die
+}
+
+src_configure() {
+       # Enable all users enabled lcd devices
+       local myeconfargs_lcd_devices
+       for lcd_device in ${IUSE_LCD_DEVICES[@]}; do
+               if use lcd_devices_${lcd_device}; then
+                       myeconfargs_lcd_devices+=",${lcd_device}"
+               fi
+       done
+
+       local use_usb="--disable-libusb"
+       if use lcd_devices_acoolsdcm || use lcd_devices_glcd2usb; then
+               use_usb="--enable-libusb"
+       fi
+
+       local myeconfargs=(
+               $(use_enable lcd_devices_directgfx libSDL)
+               $(use_enable lcd_devices_displaylink deprecated)
+               $(use_enable lcd_devices_displaylink libdlo)
+               $(use_enable lcd_devices_remote experimental)
+               $(use_enable threads pthread)
+               $(use_enable tools)
+               ${use_usb}
+               --disable-dynloading
+               --disable-statictools
+               --with-drivers="${myeconfargs_lcd_devices#,}"
+       )
+
+       econf "${myeconfargs[@]}"
+}
+
+src_install() {
+       default
+
+       udev_dorules 90-libserdisp.rules
+}
+
+pkg_postinst() {
+       udev_reload
+}
+
+pkg_postrm() {
+       udev_reload
+}