media-sound/picard: Drop old
authorAndreas Sturmlechner <asturm@gentoo.org>
Mon, 1 Oct 2018 17:49:30 +0000 (19:49 +0200)
committerAndreas Sturmlechner <asturm@gentoo.org>
Mon, 1 Oct 2018 18:12:17 +0000 (20:12 +0200)
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Package-Manager: Portage-2.3.50, Repoman-2.3.11

media-sound/picard/Manifest
media-sound/picard/picard-2.0.0_beta3.ebuild [deleted file]

index bf3d515739ce78bce95848849ae1cd77fee58c9b..56d3049fc4ea48e91099ad3854540de0ac432d1e 100644 (file)
@@ -1,2 +1 @@
-DIST picard-2.0.0_beta3.tar.gz 2686246 BLAKE2B e11cc85282bb3dfe7298090e42b62f7e9b2d4ee7df09b040905665694074ede611884e1544abc89aa3d07e0844d6599d5fac7c0db09bad7d9e64439c0c4478c9 SHA512 c8c5bdd84af3946bc24eb495bcb83877dffedb81e6ff64742925f6d1b4f2780f86280dda839d96030ea15ee2a7bf7708c20cc4ac92e97bf9cd372ea36715d156
 DIST picard-2.0.3.tar.gz 2748358 BLAKE2B ff71f9d7836b9f797a539db772e2ffcb8cb9ba4c25997c01590292bf1b7b5d311089174313af86f1eb0e82af48bc8f350578ae6bdffba3c6b3bf98b934481f8d SHA512 759252fa3c43af1bfc09d85ef90fe451e674bfebaee31838bd2779380d1b8ad817f899896baeccf583464566eb2acfe886c8288d1757faaaff2dc17c3b8ef6ae
diff --git a/media-sound/picard/picard-2.0.0_beta3.ebuild b/media-sound/picard/picard-2.0.0_beta3.ebuild
deleted file mode 100644 (file)
index b4fa770..0000000
+++ /dev/null
@@ -1,78 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python3_{5,6} )
-DISTUTILS_SINGLE_IMPL=1
-DISABLE_AUTOFORMATTING=true
-
-inherit distutils-r1 gnome2-utils readme.gentoo-r1 xdg-utils
-
-DESCRIPTION="A cross-platform music tagger"
-HOMEPAGE="https://picard.musicbrainz.org"
-SRC_URI="https://github.com/metabrainz/${PN}/archive/${PV/_beta3/dev6}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="GPL-2+"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="nls"
-
-RDEPEND="
-       dev-python/PyQt5[declarative,gui,network,widgets,${PYTHON_USEDEP}]
-       dev-qt/qtgui:5[accessibility]
-       >=media-libs/mutagen-1.38"
-DEPEND="
-       nls? ( dev-qt/linguist-tools:5 )
-"
-
-RESTRICT="test" # doesn't work with ebuilds
-
-S="${WORKDIR}/${P/_beta3/dev6}"
-
-python_compile() {
-       local build_args=(
-               --disable-autoupdate
-       )
-       if ! use nls; then
-               build_args+=( --disable-locales )
-       fi
-       distutils-r1_python_compile ${build_args[@]}
-}
-
-python_install() {
-       local install_args=(
-               --disable-autoupdate
-               --skip-build
-       )
-       if ! use nls; then
-               install_args+=( --disable-locales )
-       fi
-       distutils-r1_python_install ${install_args[@]}
-}
-
-python_install_all() {
-       distutils-r1_python_install_all
-
-       local DOC_CONTENTS="Install optional package media-libs/chromaprint[tools] to enable
-calculation and lookup of AcoustID fingerprints.
-
-Install optional package dev-python/python-discid to enable
-calculation and lookup of compact disc identifiers (disc IDs).
-
-If you are upgrading Picard and it does not start, try removing
-Picard's settings:
-       rm ~/.config/MusicBrainz/Picard.conf"
-       readme.gentoo_create_doc
-}
-
-pkg_postinst() {
-       readme.gentoo_print_elog
-       xdg_desktop_database_update
-       gnome2_icon_cache_update
-}
-
-pkg_postrm() {
-       xdg_desktop_database_update
-       gnome2_icon_cache_update
-}