kde-apps/kanagram: Add USE=speech
authorAndreas Sturmlechner <asturm@gentoo.org>
Thu, 19 Oct 2017 22:34:13 +0000 (00:34 +0200)
committerAndreas Sturmlechner <asturm@gentoo.org>
Thu, 19 Oct 2017 22:54:02 +0000 (00:54 +0200)
Upstream commit 344f730f37909e6026cfc963e8c22b81a8182ad4

Package-Manager: Portage-2.3.11, Repoman-2.3.3

kde-apps/kanagram/kanagram-17.08.2-r1.ebuild [new file with mode: 0644]
kde-apps/kanagram/metadata.xml

diff --git a/kde-apps/kanagram/kanagram-17.08.2-r1.ebuild b/kde-apps/kanagram/kanagram-17.08.2-r1.ebuild
new file mode 100644 (file)
index 0000000..3386d60
--- /dev/null
@@ -0,0 +1,44 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+KDE_HANDBOOK="true"
+inherit kde5
+
+DESCRIPTION="Game based on anagrams of words"
+HOMEPAGE="https://www.kde.org/applications/education/kanagram https://edu.kde.org/kanagram/"
+KEYWORDS="~amd64 ~x86"
+IUSE="speech"
+
+DEPEND="
+       $(add_frameworks_dep kconfig)
+       $(add_frameworks_dep kconfigwidgets)
+       $(add_frameworks_dep kcoreaddons)
+       $(add_frameworks_dep kcrash)
+       $(add_frameworks_dep kdeclarative)
+       $(add_frameworks_dep ki18n)
+       $(add_frameworks_dep knewstuff)
+       $(add_frameworks_dep kwidgetsaddons)
+       $(add_frameworks_dep kxmlgui)
+       $(add_frameworks_dep sonnet)
+       $(add_kdeapps_dep libkeduvocdocument)
+       $(add_qt_dep qtdeclarative)
+       $(add_qt_dep qtgui)
+       $(add_qt_dep qtwidgets)
+       media-libs/phonon[qt5(+)]
+       speech? ( $(add_qt_dep qtspeech) )
+"
+RDEPEND="${DEPEND}
+       $(add_kdeapps_dep kdeedu-data)
+       $(add_qt_dep qtmultimedia 'qml')
+       $(add_qt_dep qtquickcontrols)
+"
+
+src_configure() {
+       local mycmakeargs=(
+               $(cmake-utils_use_find_package speech Qt5TextToSpeech)
+       )
+
+       kde5_src_configure
+}
index 2fdbf33d963db81228cb30a4f1abf67dbe9c29f1..b337e66e249b5138c06df9cec9a2c1b719847d57 100644 (file)
@@ -5,4 +5,7 @@
                <email>kde@gentoo.org</email>
                <name>Gentoo KDE Project</name>
        </maintainer>
+       <use>
+               <flag name="speech">Enable text-to-speech support</flag>
+       </use>
 </pkgmetadata>