dev-python/iniparse: EAPI-7 bump, python3_8
authorAndreas Sturmlechner <asturm@gentoo.org>
Sun, 24 Nov 2019 15:57:04 +0000 (16:57 +0100)
committerAndreas Sturmlechner <asturm@gentoo.org>
Sun, 24 Nov 2019 17:13:33 +0000 (18:13 +0100)
Package-Manager: Portage-2.3.79, Repoman-2.3.18
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
dev-python/iniparse/iniparse-0.4-r2.ebuild

index 396e1cdef557239b57f5a6188c1fcdba636e2cd5..b00850921307fee6eb54a256ce5daca60325406c 100644 (file)
@@ -1,9 +1,9 @@
 # Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=6
-PYTHON_COMPAT=( python2_7 python3_{5,6,7} )
+EAPI=7
 
+PYTHON_COMPAT=( python2_7 python3_{5,6,7,8} )
 inherit distutils-r1
 
 DESCRIPTION="Better INI parser for Python"
@@ -15,6 +15,7 @@ SLOT="0"
 KEYWORDS="amd64 arm64 x86"
 IUSE=""
 
+BDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
 DEPEND=">=dev-python/six-1.10.0[${PYTHON_USEDEP}]"
 RDEPEND="${DEPEND}"