dev-util/nvidia-cuda-sdk: remove unnecessary slash strip.
authorBenda Xu <heroxbd@gentoo.org>
Mon, 18 Nov 2019 11:34:05 +0000 (19:34 +0800)
committerBenda Xu <heroxbd@gentoo.org>
Mon, 18 Nov 2019 11:34:28 +0000 (19:34 +0800)
Package-Manager: Portage-2.3.79, Repoman-2.3.17
Signed-off-by: Benda Xu <heroxbd@gentoo.org>
dev-util/nvidia-cuda-sdk/nvidia-cuda-sdk-10.1.243.ebuild

index 3503fb5b2caa65e6d0f74c1e3c43ec05550cbd42..e63a0c26df9120a51b89c8f00a6ea28930043138 100644 (file)
@@ -99,12 +99,12 @@ src_install() {
        if use doc; then
                ebegin "Installing docs ..."
                        while IFS="" read -d $'\0' -r f; do
-                               treecopy "${f}" "${ED%/}"/usr/share/doc/${PF}/
+                               treecopy "${f}" "${ED}"/usr/share/doc/${PF}/
                        done < <(find -type f \( -name 'readme.txt' -o -name '*.pdf' \) -print0)
 
                        while IFS="" read -d $'\0' -r f; do
-                               docompress -x "${f#${ED%/}}"
-                       done < <(find "${ED%/}"/usr/share/doc/${PF}/ -type f -name 'readme.txt' -print0)
+                               docompress -x "${f#${ED}}"
+                       done < <(find "${ED}"/usr/share/doc/${PF}/ -type f -name 'readme.txt' -print0)
                eend
        fi