version bump (bug #52560)
authorMichael Sterrett <mr_bones_@gentoo.org>
Thu, 3 Jun 2004 10:38:25 +0000 (10:38 +0000)
committerMichael Sterrett <mr_bones_@gentoo.org>
Thu, 3 Jun 2004 10:38:25 +0000 (10:38 +0000)
games-roguelike/tome/ChangeLog
games-roguelike/tome/Manifest
games-roguelike/tome/files/digest-tome-2.2.7 [new file with mode: 0644]
games-roguelike/tome/tome-2.2.7.ebuild [new file with mode: 0644]

index e94392714edcfff357dcf83d54f9f4573d6a26d1..bb8d0565344d793c1f2705b0cece4e78575fd7e9 100644 (file)
@@ -1,6 +1,11 @@
 # ChangeLog for games-roguelike/tome
 # Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-roguelike/tome/ChangeLog,v 1.8 2004/04/14 07:19:44 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-roguelike/tome/ChangeLog,v 1.9 2004/06/03 10:38:25 mr_bones_ Exp $
+
+*tome-2.2.7 (03 Jun 2004)
+
+  03 Jun 2004; Michael Sterrett <mr_bones_@gentoo.org> tome-2.2.7.ebuild:
+  version bump (bug #52560)
 
 *tome-2.2.6 (14 Apr 2004)
 
index 49505077d0c6aa9f0b12fe57f064dbed91f1d01c..8f1e90114d5eebb35f3bc48f80f051ee9d20646f 100644 (file)
@@ -1,12 +1,14 @@
-MD5 e294866c6d49c5878723ebc64b2531da ChangeLog 2448
+MD5 ba8624d09f2822e74f2ec062cf4f8638 ChangeLog 2577
 MD5 aa967ef511cf2dc52819008f3f662131 tome-2.2.6.ebuild 1725
 MD5 f17b9b8fa07a38914fe1c03268f51678 metadata.xml 158
 MD5 9f148c90d24158dc3477992dbc34e721 tome-2.2.3.ebuild 1408
 MD5 486f01e3f3f6d898bfc497c42553b5d6 tome-2.2.5.ebuild 1441
 MD5 43a5064877930e38a5ac03a125208731 tome-2.2.5-r1.ebuild 1573
+MD5 8c35479e203ea787d5c93ebd99e8bb01 tome-2.2.7.ebuild 1644
 MD5 23dd9f8f71868b8ab82d8bbbc79ad740 files/2.2.6-gentoo-paths.patch 1172
 MD5 129d70105453afe3da145b2b38cf60c9 files/digest-tome-2.2.3 62
 MD5 44a615ff66d86ba4e6b431a73ed386bc files/digest-tome-2.2.5 62
 MD5 23dd9f8f71868b8ab82d8bbbc79ad740 files/2.2.5-gentoo-paths.patch 1172
 MD5 44a615ff66d86ba4e6b431a73ed386bc files/digest-tome-2.2.5-r1 62
 MD5 5a001b935d01d828ea36c4f5b1c75419 files/digest-tome-2.2.6 65
+MD5 a23d89bdd5d10666dd7030963ba64983 files/digest-tome-2.2.7 66
diff --git a/games-roguelike/tome/files/digest-tome-2.2.7 b/games-roguelike/tome/files/digest-tome-2.2.7
new file mode 100644 (file)
index 0000000..ff83e5d
--- /dev/null
@@ -0,0 +1 @@
+MD5 3b268d1252fa509ea498bc1d303f5a95 tome-227-src.tar.bz2 2600527
diff --git a/games-roguelike/tome/tome-2.2.7.ebuild b/games-roguelike/tome/tome-2.2.7.ebuild
new file mode 100644 (file)
index 0000000..0ca89fb
--- /dev/null
@@ -0,0 +1,67 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-roguelike/tome/tome-2.2.7.ebuild,v 1.1 2004/06/03 10:38:25 mr_bones_ Exp $
+
+inherit eutils games
+
+MY_PV=${PV//./}
+DESCRIPTION="save the world from Morgoth and battle evil (or become evil ;])"
+HOMEPAGE="http://t-o-m-e.net/"
+SRC_URI="http://t-o-m-e.net/dl/src/tome-${MY_PV}-src.tar.bz2"
+
+LICENSE="Moria"
+SLOT="0"
+KEYWORDS="x86 ~ppc ~amd64"
+IUSE=""
+
+DEPEND="virtual/glibc
+       dev-lang/lua
+       >=sys-libs/ncurses-5
+       virtual/x11"
+
+S=${WORKDIR}/tome-${MY_PV}-src
+
+src_unpack() {
+       unpack ${A}
+       cp "${S}/src/makefile.std" "${S}/src/makefile" \
+       || die "cp failed"
+       find "${S}" -name .cvsignore -exec rm -f \{\} \;
+}
+
+src_compile() {
+       cd src
+       make depend || die "make depend failed"
+       emake -j1 \
+               COPTS="${CFLAGS}" \
+               BINDIR="${GAMES_BINDIR}" \
+               LIBDIR="${GAMES_DATADIR}/${PN}" \
+                       || die "emake failed"
+}
+
+src_install() {
+       cd src
+       make \
+               DESTDIR="${D}" \
+               OWNER="${GAMES_USER}" \
+               BINDIR="${GAMES_BINDIR}" \
+               LIBDIR="${GAMES_DATADIR}/${PN}" install \
+               || die "make install failed"
+       cd "${S}"
+       dodoc *.txt
+
+       dodir "${GAMES_STATEDIR}"
+       touch "${D}/${GAMES_STATEDIR}/${PN}-scores.raw"
+       prepgamesdirs
+       fperms g+w "${GAMES_STATEDIR}/${PN}-scores.raw"
+       fperms g+w "${GAMES_DATADIR}/${PN}/data"
+}
+
+pkg_postinst() {
+       games_pkg_postinst
+       echo
+       ewarn "ToME ${PV} is not save-game compatible with previous versions."
+       echo
+       einfo "If you have older save files and you wish to continue those games,"
+       einfo "you'll need to remerge the version of ToME with which you started"
+       einfo "those save-games."
+}