sci-mathematics/wxmaxima: version bump
authorAndrey Grozin <grozin@gentoo.org>
Thu, 3 Sep 2015 18:09:51 +0000 (00:09 +0600)
committerAndrey Grozin <grozin@gentoo.org>
Thu, 3 Sep 2015 18:09:51 +0000 (00:09 +0600)
Package-Manager: portage-2.2.20.1

sci-mathematics/wxmaxima/Manifest
sci-mathematics/wxmaxima/wxmaxima-15.08.1.ebuild [new file with mode: 0644]

index c48162b4c550ced9739e93c3d48136fc9079ce90..5b02cb43fdca5102c474cd7ac72ee94d846f00ad 100644 (file)
@@ -2,3 +2,5 @@ DIST wxMaxima-13.04.2.tar.gz 1652680 SHA256 29352db75dd3ff27393ab0971543fd0b3c3a
 DIST wxmaxima-15.04.0.tar.gz 4990313 SHA256 c178067a2f75d91dd378f88b4d0f87af6b2705ca32bea509d63e7347b2a1d21e SHA512 1a899259698da38f97a1859ba0526406cbc654a130dc1d18e01cf248ac4d7292c82cb00dd92ce2fac2c3cfc002788fdef0a6a4f95eca54b9096efc73c6aa45b7 WHIRLPOOL 225456c073b1aa87d2e599b9c63244ff7c97378fb6b5a60fcb8730655d193a0f032b27a1264e12eefb4abf08389f2337a11c380b6d89af2de9a4fb6e14f614dc
 DIST wxmaxima-15.08.0-missing.tar.bz2 16172 SHA256 d39d1a7937db05a4ae3e6a6d38a4079e93fb95b5533db7254de7dec7d24527db SHA512 195de1bcc4b469094716e0e417cf6431abe9f67e467c71fe51c4bed9990c613d5487cbcdda18d1df7f50e5e1b0abec7578e1091cc4999d95ba6a5f8849d826e2 WHIRLPOOL 34964f7ba5a1c9e5f2ab05b857c31b441eee43a127dc123337174509c71b7f80313e111b967abba47579021c52f27c71812c85efdf7a8429ad4e1e6c51f62db8
 DIST wxmaxima-15.08.0.tar.gz 5555560 SHA256 e6905b8e306b575e8e38b02a0e81de38be6d154d1349a455e01fbec28b21b27c SHA512 b13df571978c354ef420c613717149e3235bd5343746c12f2193eb0599f417b04cdb01e87e97ef2ed72bfd090b6ec6871c834fdb74074a3d5fb0f68bbe942263 WHIRLPOOL a2a1ae200eebb6d54a3c96cbd1c304b37c4a759ccc15983b3910d3aad1864d6c80d39e7e688198d4f3dd7c36bb9a8b2795a9610475858207b90482887219906a
+DIST wxmaxima-15.08.1-missing.tar.bz2 14699 SHA256 62a84bf32e61d39f66787a7fb2cdbf67f322ddee2d7734c23650739476e97b17 SHA512 de64163643652a288fd6f65076df94074a28895a13ae8766a1913e12833d3dbb1ae4bbdbcd6a69221e5bde7000b93e3a86a223b1320d25581d32c61ea6ab3b98 WHIRLPOOL e96dac6ffd227597721a7e8fa200d99422e722ec5d3c1733c29904fdf1f6e2bae2ba1a2c8e98e217e7a089c5857c1ccf5d10950bd98cdbde0dfb19039a60262d
+DIST wxmaxima-15.08.1.tar.gz 5577228 SHA256 82ad5314a88e53ff41dc431afb44ef1a47738686786e8cc8b4c48e0c147f4ffd SHA512 4ab7a8e992904e18e571b716d35f0d5286363b287853e3ebacc64e63df901fe192abdef16db8dc8defabb26a25f8f8956a7bad466862ee0d19d8846d4e3fec94 WHIRLPOOL 492c6ccf79640c9bfdb8d7aad283f5e0941bba8b38d037285712603112026e0feaf8873025657486df44ff718e559d9e690076e78f86e560f5d6b73ecd096ad9
diff --git a/sci-mathematics/wxmaxima/wxmaxima-15.08.1.ebuild b/sci-mathematics/wxmaxima/wxmaxima-15.08.1.ebuild
new file mode 100644 (file)
index 0000000..cdbdbcd
--- /dev/null
@@ -0,0 +1,77 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+WX_GTK_VER="3.0"
+
+inherit eutils gnome2-utils wxwidgets fdo-mime
+
+DESCRIPTION="Graphical frontend to Maxima, using the wxWidgets toolkit"
+HOMEPAGE="http://andrejv.github.io/wxmaxima/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz
+       https://dev.gentoo.org/~grozin/${P}-missing.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+DEPEND="
+       dev-libs/libxml2:2
+       x11-libs/wxGTK:${WX_GTK_VER}"
+RDEPEND="${DEPEND}
+       media-fonts/jsmath
+       sci-visualization/gnuplot[wxwidgets]
+       sci-mathematics/maxima"
+
+src_prepare() {
+       local i
+
+       # consistent package names
+       sed -e "s:\${datadir}/wxMaxima:\${datadir}/${PN}:g" \
+               -i Makefile.in data/Makefile.in test/Makefile.in || die "sed failed"
+
+       sed -e 's:share/wxMaxima:share/wxmaxima:g' \
+               -i src/wxMaxima.cpp src/wxMaximaFrame.cpp src/Dirstructure.cpp src/Dirstructure.h \
+               || die "sed failed"
+
+       # correct gettext behavior
+       if [[ -n "${LINGUAS+x}" ]] ; then
+               for i in $(cd "${S}"/locales ; echo *.mo) ; do
+                       if ! has ${i%.mo} ${LINGUAS} ; then
+                               sed -i \
+                                       -e "/^WXMAXIMA_LINGUAS/s# ${i%.mo}##" \
+                                       -e "/^WXWIN_LINGUAS/s# ${i%.mo}##" \
+                                       locales/Makefile.in || die
+                       fi
+               done
+       fi
+}
+
+src_configure() {
+       econf \
+               --enable-printing \
+               --with-wx-config=${WX_CONFIG}
+}
+
+src_install () {
+       default
+       doicon -s 128 data/wxmaxima.png
+       make_desktop_entry wxmaxima wxMaxima wxmaxima
+       dosym /usr/share/${PN}/README /usr/share/doc/${PF}/README
+}
+
+pkg_preinst() {
+       gnome2_icon_savelist
+}
+
+pkg_postinst() {
+       gnome2_icon_cache_update
+       fdo-mime_desktop_database_update
+}
+
+pkg_postrm() {
+       gnome2_icon_cache_update
+       fdo-mime_desktop_database_update
+}