sys-block/targetcli-fb: bump to 2.1.51
authorDiogo Pereira <sir.suriv@gmail.com>
Sun, 19 Apr 2020 23:00:39 +0000 (00:00 +0100)
committerJoonas Niilola <juippis@gentoo.org>
Tue, 21 Apr 2020 12:44:48 +0000 (15:44 +0300)
Closes: https://bugs.gentoo.org/696734
Reported-by: Michał Górny <mgorny@gentoo.org>
Signed-off-by: Diogo Pereira <sir.suriv@gmail.com>
Package-Manager: Portage-2.3.89, Repoman-2.3.20
Closes: https://github.com/gentoo/gentoo/pull/15431
Signed-off-by: Joonas Niilola <juippis@gentoo.org>
sys-block/targetcli-fb/Manifest
sys-block/targetcli-fb/targetcli-fb-2.1.51.ebuild [new file with mode: 0644]

index 0be8eca49fb45400407454f5413793140c24fada..4f1d7366f5e8090e9a0bad454e20255518797992 100644 (file)
@@ -1 +1,2 @@
 DIST targetcli-fb-2.1.49.tar.gz 34147 BLAKE2B 49ed4a610282af30308373cdf806832a3441dcab9a52cddb3f59bacdecb79f7308f316cc65f526d6ea1f9bb875d05e049e6cd7d99eb243f25546395ba6aaa38c SHA512 05fb6f638f808bf09089bdd110592b3ed3be49fc70cc1a71680de7bff40dc88425e69e9a99fdfcab712646cf131f78071edae46f214fdfee4b7090f47933c93a
+DIST targetcli-fb-2.1.51.tar.gz 38577 BLAKE2B 0cc1cc920ec7bcefb987fac0397aa7c5a994cf47966971238a6c469e87b2dffc00dc09a55279b5ba0fda776a32a129ad3170b861e6309ea30f271ddc32f690f6 SHA512 a94f251889913888c430cfe2b2fa1b27e4cd01f05627f1c3f0d4c72145b23081be189b7ca5d381bffa0da74ba6a53146e7ca964ff864cb532f132e24bc205b9a
diff --git a/sys-block/targetcli-fb/targetcli-fb-2.1.51.ebuild b/sys-block/targetcli-fb/targetcli-fb-2.1.51.ebuild
new file mode 100644 (file)
index 0000000..fe0c14a
--- /dev/null
@@ -0,0 +1,28 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7} )
+inherit distutils-r1
+
+DESCRIPTION="Command shell for managing Linux LIO kernel target"
+HOMEPAGE="https://github.com/open-iscsi/targetcli-fb"
+SRC_URI="https://github.com/open-iscsi/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-python/configshell-fb[${PYTHON_USEDEP}]
+       dev-python/pygobject:3[${PYTHON_USEDEP}]
+       dev-python/rtslib-fb[${PYTHON_USEDEP}]
+       dev-python/six[${PYTHON_USEDEP}]
+       sys-apps/dbus"
+
+src_install() {
+       distutils-r1_src_install
+
+       keepdir /etc/target /etc/target/backup
+       doman targetcli.8
+}