net-libs/kdsoap-ws-discovery-client: New package
authorAndreas Sturmlechner <asturm@gentoo.org>
Thu, 19 Mar 2020 14:33:35 +0000 (15:33 +0100)
committerAndreas Sturmlechner <asturm@gentoo.org>
Thu, 19 Mar 2020 14:33:35 +0000 (15:33 +0100)
Bug: https://bugs.gentoo.org/489446
Package-Manager: Portage-2.3.94, Repoman-2.3.21
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
net-libs/kdsoap-ws-discovery-client/Manifest [new file with mode: 0644]
net-libs/kdsoap-ws-discovery-client/files/kdsoap-ws-discovery-client-0.2_pre20200317-deps.patch [new file with mode: 0644]
net-libs/kdsoap-ws-discovery-client/files/kdsoap-ws-discovery-client-0.2_pre20200317-no-install-docs.patch [new file with mode: 0644]
net-libs/kdsoap-ws-discovery-client/kdsoap-ws-discovery-client-0.2_pre20200317.ebuild [new file with mode: 0644]
net-libs/kdsoap-ws-discovery-client/metadata.xml [new file with mode: 0644]

diff --git a/net-libs/kdsoap-ws-discovery-client/Manifest b/net-libs/kdsoap-ws-discovery-client/Manifest
new file mode 100644 (file)
index 0000000..83d1d97
--- /dev/null
@@ -0,0 +1 @@
+DIST kdsoap-ws-discovery-client-0.2_pre20200317.tar.gz 37395 BLAKE2B 03bee2d6f87a3fb407e0cff7e84f9bd83814d742f714630b8c469b26a139062472ad39a0f743caac6f5de4ae2c8a55c42b56ee14c6afcd3a0a874c3f0d9978c5 SHA512 f99092e06e4d7496d6fe79e4cf78265c072476159da958c2a0ee7b852be00b16c89582a8c69c5cbe4160a6419435ee2d8bc71bce40ea9753eaf458c34df6f86b
diff --git a/net-libs/kdsoap-ws-discovery-client/files/kdsoap-ws-discovery-client-0.2_pre20200317-deps.patch b/net-libs/kdsoap-ws-discovery-client/files/kdsoap-ws-discovery-client-0.2_pre20200317-deps.patch
new file mode 100644 (file)
index 0000000..f8f6c08
--- /dev/null
@@ -0,0 +1,9 @@
+--- a/KDSoapWSDiscoveryClientConfig.cmake.in   2020-03-02 23:38:05.253097303 +0100
++++ b/KDSoapWSDiscoveryClientConfig.cmake.in   2020-03-02 23:39:03.346641208 +0100
+@@ -5,5 +5,6 @@
+ @PACKAGE_INIT@
+ find_dependency(Qt5Core @REQUIRED_QT_VERSION@)
++find_dependency(KDSoap)
+ include("${CMAKE_CURRENT_LIST_DIR}/KDSoapWSDiscoveryClientTargets.cmake")
diff --git a/net-libs/kdsoap-ws-discovery-client/files/kdsoap-ws-discovery-client-0.2_pre20200317-no-install-docs.patch b/net-libs/kdsoap-ws-discovery-client/files/kdsoap-ws-discovery-client-0.2_pre20200317-no-install-docs.patch
new file mode 100644 (file)
index 0000000..5e2cb6d
--- /dev/null
@@ -0,0 +1,13 @@
+Do not trigger QA with the paths we want our docs in.
+
+--- a/docs/CMakeLists.txt      2020-03-02 23:10:28.358584552 +0100
++++ b/docs/CMakeLists.txt      2020-03-02 23:11:52.228369765 +0100
+@@ -29,8 +29,4 @@
+         USE_STAMP_FILE
+         WORKING_DIRECTORY ${CMAKE_CURRENT_SOURCE_DIR}/..
+         )
+-    install(DIRECTORY
+-            ${CMAKE_CURRENT_BINARY_DIR}/html/
+-        DESTINATION ${KDE_INSTALL_DATADIR}/doc/KDSoapWSDiscoveryClient
+-        COMPONENT Devel)
+ endif()
diff --git a/net-libs/kdsoap-ws-discovery-client/kdsoap-ws-discovery-client-0.2_pre20200317.ebuild b/net-libs/kdsoap-ws-discovery-client/kdsoap-ws-discovery-client-0.2_pre20200317.ebuild
new file mode 100644 (file)
index 0000000..ac8ee19
--- /dev/null
@@ -0,0 +1,62 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+ECM_QTHELP="false"
+ECM_TEST="forceoptional"
+inherit ecm
+
+if [[ ${PV} != *9999* ]]; then
+       COMMIT=14287e92e80a77aa4c0adee2871e6b87c9c3055e
+       SRC_URI="https://gitlab.com/caspermeijn/${PN}/repository/${COMMIT}/archive.tar.gz -> ${P}.tar.gz"
+       KEYWORDS="~amd64"
+       S="${WORKDIR}/${PN}-${COMMIT}-${COMMIT}"
+else
+       EGIT_REPO_URI="https://gitlab.com/caspermeijn/${PN}.git"
+       inherit git-r3
+fi
+
+DESCRIPTION="WS-Discovery client library based on KDSoap"
+HOMEPAGE="https://gitlab.com/caspermeijn/kdsoap-ws-discovery-client
+https://caspermeijn.gitlab.io/kdsoap-ws-discovery-client"
+
+LICENSE="CC0-1.0 GPL-3+"
+SLOT="0"
+IUSE="doc"
+
+BDEPEND="
+       doc? ( app-doc/doxygen[dot] )
+"
+RDEPEND="
+       dev-qt/qtcore:5
+       dev-qt/qtnetwork:5
+       >=net-libs/kdsoap-1.9.0"
+DEPEND="${RDEPEND}
+       test? ( dev-qt/qtxml:5 )
+"
+
+RESTRICT+=" test"
+
+PATCHES=(
+       "${FILESDIR}"/${P}-no-install-docs.patch
+       "${FILESDIR}"/${P}-deps.patch
+)
+
+src_prepare() {
+       ecm_src_prepare
+       use test || ecm_punt_bogus_dep Qt5 Xml
+}
+
+src_configure() {
+       local mycmakeargs=(
+               $(cmake_use_find_package doc Doxygen)
+               -DBUILD_QCH=OFF # does not use ecm_add_qch from ECMAddQch
+       )
+       ecm_src_configure
+}
+
+src_install() {
+       use doc && local HTML_DOCS=( "${BUILD_DIR}"/docs/html/. )
+       ecm_src_install
+}
diff --git a/net-libs/kdsoap-ws-discovery-client/metadata.xml b/net-libs/kdsoap-ws-discovery-client/metadata.xml
new file mode 100644 (file)
index 0000000..2fdbf33
--- /dev/null
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+       <maintainer type="project">
+               <email>kde@gentoo.org</email>
+               <name>Gentoo KDE Project</name>
+       </maintainer>
+</pkgmetadata>