app-misc/khard: add tests
authorAndrey Utkin <andrey_utkin@gentoo.org>
Mon, 28 Jan 2019 02:16:39 +0000 (02:16 +0000)
committerAndrey Utkin <andrey_utkin@gentoo.org>
Mon, 28 Jan 2019 02:24:07 +0000 (02:24 +0000)
Test suite has been added in 0.13.3 release.

Package-Manager: Portage-2.3.49, Repoman-2.3.12
Signed-off-by: Andrey Utkin <andrey_utkin@gentoo.org>
app-misc/khard/khard-0.13.0.ebuild

index fcba0a4d09b37d378a09166d59dc340a17a635e7..335ff71ec05467ea3a2f619e416eb1f7048968ea 100644 (file)
@@ -8,7 +8,7 @@ DESCRIPTION="Console CardDAV client"
 HOMEPAGE="https://github.com/scheibler/khard"
 LICENSE="GPL-3"
 SLOT="0"
-IUSE="zsh-completion"
+IUSE="test zsh-completion"
 
 if [ "${PV}" == "9999" ]; then
        inherit git-r3
@@ -18,7 +18,6 @@ else
        KEYWORDS="~amd64 ~arm64"
 fi
 
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
 RDEPEND="
        dev-python/atomicwrites[${PYTHON_USEDEP}]
        dev-python/configobj[${PYTHON_USEDEP}]
@@ -26,6 +25,12 @@ RDEPEND="
        dev-python/unidecode[${PYTHON_USEDEP}]
        >dev-python/vobject-0.9.3[${PYTHON_USEDEP}]
 "
+DEPEND="
+       dev-python/setuptools[${PYTHON_USEDEP}]
+       test? (
+               ${RDEPEND}
+       )
+"
 # vobject-0.9.3 breaks khard, see
 # https://github.com/scheibler/khard/issues/87
 # https://github.com/eventable/vobject/issues/39
@@ -40,3 +45,7 @@ src_install() {
                doins misc/zsh/_khard
        fi
 }
+
+python_test() {
+       esetup.py test
+}