dev-php/composer: Add version bump 1.5.5
authorGuillaume Seren <guillaumeseren@gmail.com>
Sun, 3 Dec 2017 12:38:55 +0000 (13:38 +0100)
committerMichael Orlitzky <mjo@gentoo.org>
Sun, 3 Dec 2017 15:04:35 +0000 (10:04 -0500)
Package-Manager: Portage-2.3.13, Repoman-2.3.3

Closes: https://bugs.gentoo.org/639504

Signed-off-by: Michael Orlitzky <mjo@gentoo.org>
dev-php/composer/Manifest
dev-php/composer/composer-1.5.5.ebuild [new file with mode: 0644]

index a2e5517ffc499a4c743a184f881ccd121f46710f..2be9f23c31d52ad3b19d66dc1e0b7e4ee1553c3b 100644 (file)
@@ -1 +1,2 @@
 DIST composer-1.5.2.tar.gz 1100976 SHA256 e8af65669563890364ec73ed57f589b1200f03fd86edc925a9961235aff5f54d SHA512 929b054dc2742f0043fe82374d0fdcd3ff073fb4fb1dc7eedca0e9a2c90dc00ab11b6a20ab2c549c0429fb3d0836f5590a3970a3bfbde5795fe5a665ea286dbb WHIRLPOOL 05f18eead21dc02a20a274ce4dd11805cd7e95228492a7c17dd8e09d56daa577620f12b68e5983daf6df3b6d952b44ad77d49338692fe05601ca699ac57c0824
+DIST composer-1.5.5.tar.gz 1102418 BLAKE2B b8a29ab7473e439d0ff71ba5eb21a63a1c10a3f805c076c3af4f0fd46f5fe7a216085e999d3dd23ca78d769661d1bbfdf04ecf3c353428f6326735ddc564945a SHA512 c1021d1fb5ef992ea16023b982aa8ccdfddf7bce5da0945847ed28c555e795e7d23d4f0892e98d745784ab702e332217ea240ae6297bb18638b5161b6d7c84f0
diff --git a/dev-php/composer/composer-1.5.5.ebuild b/dev-php/composer/composer-1.5.5.ebuild
new file mode 100644 (file)
index 0000000..7e9f959
--- /dev/null
@@ -0,0 +1,46 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Dependency Manager for PHP"
+HOMEPAGE="https://github.com/composer/composer"
+SRC_URI="${HOMEPAGE}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+       dev-lang/php:*[curl]
+       >=dev-php/ca-bundle-1.0.0
+       >=dev-php/cli-prompt-1.0.0
+       >=dev-php/psr-log-1.0.2
+       dev-php/fedora-autoloader
+       >=dev-php/json-schema-3.0.0
+       >=dev-php/jsonlint-1.4.0
+       >=dev-php/phar-utils-1.0.0
+       >=dev-php/semver-1.0.0
+       >=dev-php/spdx-licenses-1.0.0
+       >=dev-php/symfony-console-2.7.9
+       >=dev-php/symfony-filesystem-2.7.20
+       >=dev-php/symfony-finder-2.7.20
+       >=dev-php/symfony-process-2.8.12"
+
+src_install() {
+       insinto "/usr/share/${PN}"
+
+       # Composer expects the LICENSE file to be there, and the
+       # easiest thing to do is to give it what it wants.
+       doins -r src res LICENSE
+
+       insinto "/usr/share/${PN}/vendor"
+       doins "${FILESDIR}"/autoload.php
+
+       exeinto "/usr/share/${PN}/bin"
+       doexe "bin/${PN}"
+       dosym "/usr/share/${PN}/bin/${PN}" "/usr/bin/${PN}"
+
+       dodoc CHANGELOG.md README.md doc/*.md
+       dodoc -r doc/articles doc/faqs
+}