New developer snapshot.
authorHenrik Brix Andersen <brix@gentoo.org>
Wed, 21 Jun 2006 19:59:36 +0000 (19:59 +0000)
committerHenrik Brix Andersen <brix@gentoo.org>
Wed, 21 Jun 2006 19:59:36 +0000 (19:59 +0000)
Package-Manager: portage-2.1

net-wireless/hostapd/ChangeLog
net-wireless/hostapd/files/digest-hostapd-0.5.3
net-wireless/hostapd/files/digest-hostapd-0.5.4 [new file with mode: 0644]
net-wireless/hostapd/files/hostapd-0.5.4-conf.d [new file with mode: 0644]
net-wireless/hostapd/files/hostapd-0.5.4-init.d [new file with mode: 0644]
net-wireless/hostapd/hostapd-0.5.4.ebuild [new file with mode: 0644]
net-wireless/wpa_supplicant/ChangeLog
net-wireless/wpa_supplicant/files/digest-wpa_supplicant-0.5.3
net-wireless/wpa_supplicant/files/digest-wpa_supplicant-0.5.4 [new file with mode: 0644]
net-wireless/wpa_supplicant/files/wpa_supplicant-0.5.4-wpa_cli.sh [new file with mode: 0644]
net-wireless/wpa_supplicant/wpa_supplicant-0.5.4.ebuild [new file with mode: 0644]

index 5cc3668fe6d3c5f997255e04a99d570806df656d..d69611076a514c0c569a944f94bc2bf2df7ca45e 100644 (file)
@@ -1,6 +1,13 @@
 # ChangeLog for net-wireless/hostapd
 # Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-wireless/hostapd/ChangeLog,v 1.64 2006/05/27 19:57:22 brix Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/hostapd/ChangeLog,v 1.65 2006/06/21 19:59:36 brix Exp $
+
+*hostapd-0.5.4 (21 Jun 2006)
+
+  21 Jun 2006; Henrik Brix Andersen <brix@gentoo.org>
+  +files/hostapd-0.5.4-conf.d, +files/hostapd-0.5.4-init.d,
+  +hostapd-0.5.4.ebuild:
+  New developer snapshot.
 
 *hostapd-0.4.9 (27 May 2006)
 
index b26698dd068ceabc784c4aff4fdf08d384a3b164..0bacfb28490f05abfb8df5b5abf4560d3c1217f9 100644 (file)
@@ -1 +1,3 @@
 MD5 4e3134e8b0d86e831230f8c620fd81bb hostapd-0.5.3.tar.gz 385649
+RMD160 9914c9d26c264bfbab52ef722a81a49fad9190a4 hostapd-0.5.3.tar.gz 385649
+SHA256 8681a00adf9478e37fb5b2423ed73af671f69f7e75d86ba49933b20cef9100b4 hostapd-0.5.3.tar.gz 385649
diff --git a/net-wireless/hostapd/files/digest-hostapd-0.5.4 b/net-wireless/hostapd/files/digest-hostapd-0.5.4
new file mode 100644 (file)
index 0000000..34d85dd
--- /dev/null
@@ -0,0 +1,3 @@
+MD5 18e203b3038f8d12fbf5924e60cfd6f3 hostapd-0.5.4.tar.gz 395052
+RMD160 14f4de6f99ef37d2e80ead2b30195a7c0cb17350 hostapd-0.5.4.tar.gz 395052
+SHA256 0c4865d24f9b27f68cb293ee1a9f8b4f60d1c4ab8daf32b46a65f0f5d7a47234 hostapd-0.5.4.tar.gz 395052
diff --git a/net-wireless/hostapd/files/hostapd-0.5.4-conf.d b/net-wireless/hostapd/files/hostapd-0.5.4-conf.d
new file mode 100644 (file)
index 0000000..7d05735
--- /dev/null
@@ -0,0 +1,9 @@
+# Space separated List of interfaces which needs to be started before
+# hostapd
+INTERFACES="wlan0"
+
+# Space separated list of configuration files
+CONFIGS="/etc/hostapd/hostapd.conf"
+
+# Extra options to pass to hostapd, see hostapd(8)
+OPTIONS=""
diff --git a/net-wireless/hostapd/files/hostapd-0.5.4-init.d b/net-wireless/hostapd/files/hostapd-0.5.4-init.d
new file mode 100644 (file)
index 0000000..ed54fde
--- /dev/null
@@ -0,0 +1,50 @@
+#!/sbin/runscript
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/hostapd/files/hostapd-0.5.4-init.d,v 1.1 2006/06/21 19:59:36 brix Exp $
+
+opts="start stop reload"
+
+depend() {
+       local iface
+
+       for iface in ${INTERFACES}; do
+               need net.${iface}
+       done
+
+       use logger
+}
+
+checkconfig() {
+       local file
+
+       for file in ${CONFIGS}; do
+               if [[ ! -r ${file} ]]; then
+                       eerror "hostapd configuration file (${CONFIG}) not found"
+                       return 1
+               fi
+       done
+}
+
+start() {
+       checkconfig || return 1
+
+       ebegin "Starting hostapd"
+       start-stop-daemon --start --exec /usr/sbin/hostapd \
+               -- -B ${OPTIONS} ${CONFIGS}
+       eend ${?}
+}
+
+stop() {
+       ebegin "Stopping hostapd"
+       start-stop-daemon --stop --exec /usr/sbin/hostapd
+       eend ${?}
+}
+
+reload() {
+       checkconfig || return 1
+
+       ebegin "Reloading hostapd configuration"
+       kill -HUP $(pidof /usr/sbin/hostapd) > /dev/null 2>&1
+       eend ${?}
+}
diff --git a/net-wireless/hostapd/hostapd-0.5.4.ebuild b/net-wireless/hostapd/hostapd-0.5.4.ebuild
new file mode 100644 (file)
index 0000000..8ee3527
--- /dev/null
@@ -0,0 +1,129 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/hostapd/hostapd-0.5.4.ebuild,v 1.1 2006/06/21 19:59:36 brix Exp $
+
+inherit toolchain-funcs
+
+DESCRIPTION="IEEE 802.11 wireless LAN Host AP daemon"
+HOMEPAGE="http://hostap.epitest.fi"
+SRC_URI="http://hostap.epitest.fi/releases/${P}.tar.gz"
+
+LICENSE="|| ( GPL-2 BSD )"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+IUSE="ipv6 logwatch madwifi ssl"
+
+RDEPEND="ssl? ( dev-libs/openssl )
+               madwifi? ( || ( net-wireless/madwifi-ng net-wireless/madwifi-old ) )"
+DEPEND="${RDEPEND}
+               sys-apps/sed"
+
+src_unpack() {
+       local CONFIG=${S}/.config
+
+       unpack ${A}
+
+       sed -i -e "s:/etc/hostapd:/etc/hostapd/hostapd:g" \
+               ${S}/hostapd.conf
+
+       # toolchain setup
+       echo "CC = $(tc-getCC)" > ${CONFIG}
+
+       # authentication methods
+       echo "CONFIG_EAP=y"           >> ${CONFIG}
+       echo "CONFIG_EAP_AKA=y"       >> ${CONFIG}
+       echo "CONFIG_EAP_GTC=y"       >> ${CONFIG}
+       echo "CONFIG_EAP_MD5=y"       >> ${CONFIG}
+       echo "CONFIG_EAP_PAX=y"       >> ${CONFIG}
+       echo "CONFIG_EAP_PSK=y"       >> ${CONFIG}
+       echo "CONFIG_EAP_SIM=y"       >> ${CONFIG}
+       echo "CONFIG_EAP_TLV=y"       >> ${CONFIG}
+       echo "CONFIG_IAPP=y"          >> ${CONFIG}
+       echo "CONFIG_PKCS12=y"        >> ${CONFIG}
+       echo "CONFIG_RADIUS_SERVER=y" >> ${CONFIG}
+       echo "CONFIG_RSN_PREAUTH=y"   >> ${CONFIG}
+       echo "CONFIG_PEERKEY=y"       >> ${CONFIG}
+
+       if use ssl; then
+               # SSL authentication methods
+               echo "CONFIG_EAP_MSCHAPV2=y" >> ${CONFIG}
+               echo "CONFIG_EAP_PEAP=y"     >> ${CONFIG}
+               echo "CONFIG_EAP_TLS=y"      >> ${CONFIG}
+               echo "CONFIG_EAP_TTLS=y"     >> ${CONFIG}
+       fi
+
+       if use ipv6; then
+               echo "CONFIG_IPV6=y" >> ${CONFIG}
+       fi
+
+       # Linux specific drivers
+       echo "CONFIG_DRIVER_HOSTAP=y"      >> ${CONFIG}
+       echo "CONFIG_DRIVER_PRISM54=y"     >> ${CONFIG}
+       echo "CONFIG_DRIVER_WIRED=y"       >> ${CONFIG}
+
+       if use madwifi; then
+               # Add include path for madwifi-driver headers
+               echo "CFLAGS += -I${ROOT}/usr/include/madwifi" >> ${CONFIG}
+               echo "CONFIG_DRIVER_MADWIFI=y"                 >> ${CONFIG}
+       fi
+}
+
+src_compile() {
+       emake || die "emake failed"
+
+       if use ssl; then
+               emake nt_password_hash || die "emake nt_password_hash failed"
+               emake hlr_auc_gw || die "emake hlr_auc_gw failed"
+       fi
+}
+
+src_install() {
+       insinto /etc/hostapd
+       doins hostapd.conf hostapd.accept hostapd.deny \
+               hostapd.eap_user hostapd.radius_clients hostapd.sim_db hostapd.wpa_psk
+
+       dosbin hostapd
+       dobin hostapd_cli
+       use ssl && dobin nt_password_hash
+       use ssl && dobin hlr_auc_gw
+
+       newinitd ${FILESDIR}/${P}-init.d hostapd
+       newconfd ${FILESDIR}/${P}-conf.d hostapd
+
+       doman hostapd.8 hostapd_cli.1
+
+       dodoc ChangeLog developer.txt README
+
+       docinto examples
+       dodoc madwifi.conf wired.conf
+
+       if use logwatch; then
+               insinto /etc/log.d/conf/services/
+               doins logwatch/hostapd.conf
+
+               exeinto /etc/log.d/scripts/services/
+               doexe logwatch/hostapd
+       fi
+}
+
+pkg_postinst() {
+       einfo
+       einfo "In order to use ${PN} you need to set up your wireless card"
+       einfo "for master mode in /etc/conf.d/net or /etc/conf.d/wireless"
+       einfo "and then start /etc/init.d/hostapd."
+       einfo
+       einfo "Example configuration:"
+       einfo
+       einfo "config_wlan0=( \"192.168.1.1/24\" )"
+       einfo "channel_wlan0=\"6\""
+       einfo "essid_wlan0=\"test\""
+       einfo "mode_wlan0=\"master\""
+       einfo
+       if use madwifi; then
+               einfo "This package now compiles against the headers installed by"
+               einfo "the madwifi driver. You should remerge ${PN} after"
+               einfo "upgrading your madwifi driver."
+               einfo
+       fi
+}
index bdfd05a05fb5708c5805890254732b1dfe498997..d781860bff6ae25e3843c0318967eba30628aa0c 100644 (file)
@@ -1,6 +1,12 @@
 # ChangeLog for net-wireless/wpa_supplicant
 # Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-wireless/wpa_supplicant/ChangeLog,v 1.60 2006/05/27 20:01:35 brix Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/wpa_supplicant/ChangeLog,v 1.61 2006/06/21 19:58:07 brix Exp $
+
+*wpa_supplicant-0.5.4 (21 Jun 2006)
+
+  21 Jun 2006; Henrik Brix Andersen <brix@gentoo.org>
+  +files/wpa_supplicant-0.5.4-wpa_cli.sh, +wpa_supplicant-0.5.4.ebuild:
+  New developer snapshot.
 
 *wpa_supplicant-0.4.9 (27 May 2006)
 
index f614e47939986f2f843b9edc77b18c1bf515f151..a210581e2059762aa1d863c1e8b23c5413875448 100644 (file)
@@ -1 +1,3 @@
 MD5 f30cd996ebdd9f1f6aeab65f8cfac3c3 wpa_supplicant-0.5.3.tar.gz 543322
+RMD160 d3911460fcd4b3cc85bfc41bfb98235c447bfd43 wpa_supplicant-0.5.3.tar.gz 543322
+SHA256 cf29745c4c11fd8d7668d9a7ad0f698160b1f8f0988146175908d877dda71236 wpa_supplicant-0.5.3.tar.gz 543322
diff --git a/net-wireless/wpa_supplicant/files/digest-wpa_supplicant-0.5.4 b/net-wireless/wpa_supplicant/files/digest-wpa_supplicant-0.5.4
new file mode 100644 (file)
index 0000000..6277e57
--- /dev/null
@@ -0,0 +1,3 @@
+MD5 eaf78fa5dde04ee20e718a8e94eed827 wpa_supplicant-0.5.4.tar.gz 630779
+RMD160 34074a4d1ebab4d455eb021a18ef9012943b1fd9 wpa_supplicant-0.5.4.tar.gz 630779
+SHA256 6c14c9c6c68acc40aa1c860d4fde58424c57b48ea90700da189e6cf5c1dd6bd7 wpa_supplicant-0.5.4.tar.gz 630779
diff --git a/net-wireless/wpa_supplicant/files/wpa_supplicant-0.5.4-wpa_cli.sh b/net-wireless/wpa_supplicant/files/wpa_supplicant-0.5.4-wpa_cli.sh
new file mode 100644 (file)
index 0000000..996aa94
--- /dev/null
@@ -0,0 +1,45 @@
+#!/bin/sh
+# Copyright 1999-2006 Gentoo Foundation
+# Written by Roy Marples <uberlord@gentoo.org>
+# Distributed under the terms of the GNU General Public License v2
+# Alternatively, this file may be distributed under the terms of the BSD License
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/wpa_supplicant/files/wpa_supplicant-0.5.4-wpa_cli.sh,v 1.1 2006/06/21 19:58:07 brix Exp $
+
+if [ -z "$1" -o -z "$2" ]; then
+       echo "Insufficient parameters" > /dev/stderr
+       exit 1
+fi
+
+INTERFACE="$1"
+ACTION="$2"
+
+# Note, the below action must NOT mark the interface down via ifconfig, ip or
+# similar. Addresses can be removed, changed and daemons can be stopped, but
+# the interface must remain up for wpa_supplicant to work.
+
+if [ -f /etc/gentoo-release ]; then
+       EXEC="/etc/init.d/net.${INTERFACE} --quiet"
+else
+       echo "I don't know what to do with this distro!" > /dev/stderr
+       exit 1
+fi
+
+case ${ACTION} in
+       CONNECTED)
+               EXEC="${EXEC} start"
+               ;;
+       DISCONNECTED)
+               EXEC="${EXEC} stop"
+               ;;
+       *)
+               echo "Unknown action ${ACTION}" > /dev/stderr
+               exit 1
+               ;;
+esac
+
+# ${EXEC} can use ${IN_BACKGROUND} so that it knows that the user isn't
+# stopping the interface and a background process - like wpa_cli - is.
+export IN_BACKGROUND=true
+
+logger -t wpa_cli "interface ${INTERFACE} ${ACTION}"
+${EXEC} || logger -t wpa_cli "executing '${EXEC}' failed"
diff --git a/net-wireless/wpa_supplicant/wpa_supplicant-0.5.4.ebuild b/net-wireless/wpa_supplicant/wpa_supplicant-0.5.4.ebuild
new file mode 100644 (file)
index 0000000..d98b767
--- /dev/null
@@ -0,0 +1,158 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/wpa_supplicant/wpa_supplicant-0.5.4.ebuild,v 1.1 2006/06/21 19:58:07 brix Exp $
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="IEEE 802.1X/WPA supplicant for secure wireless transfers"
+HOMEPAGE="http://hostap.epitest.fi/wpa_supplicant/"
+SRC_URI="http://hostap.epitest.fi/releases/${P}.tar.gz"
+LICENSE="|| ( GPL-2 BSD )"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="dbus gsm madwifi qt readline ssl"
+
+RDEPEND="dbus? ( sys-apps/dbus )
+               gsm? ( sys-apps/pcsc-lite )
+               qt? ( =x11-libs/qt-4* )
+               readline? ( sys-libs/ncurses sys-libs/readline )
+               ssl? ( dev-libs/openssl )
+               kernel_linux? ( madwifi? ( || ( net-wireless/madwifi-ng net-wireless/madwifi-old ) ) )
+               !kernel_linux? ( net-libs/libpcap )"
+DEPEND="sys-apps/sed
+               ${RDEPEND}"
+
+src_unpack() {
+       local CONFIG=${S}/.config
+
+       unpack ${A}
+
+       # net/bpf.h needed for net-libs/libpcap on Gentoo FreeBSD
+       sed -i \
+               -e "s:\(#include <pcap\.h>\):#include <net/bpf.h>\n\1:" \
+               ${S}/l2_packet_freebsd.c
+
+       # toolchain setup
+       echo "CC = $(tc-getCC)" > ${CONFIG}
+
+       # basic setup
+       echo "CONFIG_CTRL_IFACE=y" >> ${CONFIG}
+       echo "CONFIG_BACKEND=file" >> ${CONFIG}
+
+       # basic authentication methods
+       echo "CONFIG_EAP_GTC=y"         >> ${CONFIG}
+       echo "CONFIG_EAP_MD5=y"         >> ${CONFIG}
+       echo "CONFIG_EAP_OTP=y"         >> ${CONFIG}
+       echo "CONFIG_EAP_PAX=y"         >> ${CONFIG}
+       echo "CONFIG_EAP_PSK=y"         >> ${CONFIG}
+       echo "CONFIG_EAP_TLV=y"         >> ${CONFIG}
+       echo "CONFIG_IEEE8021X_EAPOL=y" >> ${CONFIG}
+       echo "CONFIG_PKCS12=y"          >> ${CONFIG}
+       echo "CONFIG_PEERKEY=y"         >> ${CONFIG}
+
+       if use dbus; then
+               echo "CONFIG_CTRL_IFACE_DBUS=y" >> ${CONFIG}
+       fi
+
+       if use gsm; then
+               # smart card authentication
+               echo "CONFIG_EAP_SIM=y" >> ${CONFIG}
+               echo "CONFIG_EAP_AKA=y" >> ${CONFIG}
+               echo "CONFIG_PCSC=y"    >> ${CONFIG}
+       fi
+
+       if use readline; then
+               # readline/history support for wpa_cli
+               echo "CONFIG_READLINE=y" >> ${CONFIG}
+       fi
+
+       if use ssl; then
+               # SSL authentication methods
+               echo "CONFIG_EAP_LEAP=y"     >> ${CONFIG}
+               echo "CONFIG_EAP_MSCHAPV2=y" >> ${CONFIG}
+               echo "CONFIG_EAP_PEAP=y"     >> ${CONFIG}
+               echo "CONFIG_EAP_TLS=y"      >> ${CONFIG}
+               echo "CONFIG_EAP_TTLS=y"     >> ${CONFIG}
+               echo "CONFIG_SMARTCARD=y"    >> ${CONFIG}
+       fi
+
+       if use kernel_linux; then
+               # Linux specific drivers
+               echo "CONFIG_DRIVER_ATMEL=y"       >> ${CONFIG}
+               echo "CONFIG_DRIVER_HOSTAP=y"      >> ${CONFIG}
+               echo "CONFIG_DRIVER_IPW=y"         >> ${CONFIG}
+               echo "CONFIG_DRIVER_NDISWRAPPER=y" >> ${CONFIG}
+               echo "CONFIG_DRIVER_PRISM54=y"     >> ${CONFIG}
+               echo "CONFIG_DRIVER_WEXT=y"        >> ${CONFIG}
+               echo "CONFIG_DRIVER_WIRED=y"       >> ${CONFIG}
+
+               if use madwifi; then
+                       # Add include path for madwifi-driver headers
+                       echo "CFLAGS += -I${ROOT}/usr/include/madwifi" >> ${CONFIG}
+                       echo "CONFIG_DRIVER_MADWIFI=y"                 >> ${CONFIG}
+               fi
+       fi
+
+       if use kernel_FreeBSD; then
+               # FreeBSD specific driver
+               echo "CONFIG_DRIVER_BSD=y" >> ${CONFIG}
+       fi
+
+       # people seem to take the example configuration file too literally
+       # bug #102361
+       sed -i \
+               -e "s:^\(opensc_engine_path\):#\1:" \
+               -e "s:^\(pkcs11_engine_path\):#\1:" \
+               -e "s:^\(pkcs11_module_path\):#\1:" \
+               ${S}/wpa_supplicant.conf || die
+}
+
+src_compile() {
+       emake || die "emake failed"
+
+       if use qt; then
+               qmake -o "${S}"/wpa_gui-qt4/Makefile "${S}"/wpa_gui-qt4/wpa_gui.pro
+               cd "${S}"/wpa_gui-qt4
+               emake || die "emake wpa_gui-qt4 failed"
+       fi
+}
+
+src_install() {
+       into /
+       dosbin wpa_supplicant
+       dobin wpa_cli wpa_passphrase
+
+       exeinto /etc/wpa_supplicant/
+       newexe ${FILESDIR}/${P}-wpa_cli.sh wpa_cli.sh
+
+       # compatibility symlink for older baselayout
+       dosym /etc/wpa_supplicant/wpa_cli.sh /sbin/wpa_cli.action
+
+       if use qt; then
+               into /usr
+               dobin wpa_gui-qt4/wpa_gui
+       fi
+
+       dodoc ChangeLog COPYING eap_testing.txt README todo.txt
+       newdoc wpa_supplicant.conf wpa_supplicant.conf.example
+
+       doman doc/docbook/*.8
+       doman doc/docbook/*.5
+}
+
+pkg_postinst() {
+       einfo
+       einfo "To use ${MY_P} you must create the configuration file"
+       einfo "/etc/wpa_supplicant/wpa_supplicant.conf"
+       einfo
+       einfo "An example configuration file is available as"
+       einfo "/usr/share/doc/${PF}/wpa_supplicant.conf.example.gz"
+       einfo
+       if use madwifi; then
+               einfo "This package now compiles against the headers installed by"
+               einfo "the madwifi driver. You should reemerge ${PN} after"
+               einfo "upgrading your madwifi driver."
+               einfo
+       fi
+}