dev-tex/leaflet: bump EAPI and stuff
authorAaron Bauman <bman@gentoo.org>
Sat, 9 Nov 2019 20:38:08 +0000 (15:38 -0500)
committerAaron Bauman <bman@gentoo.org>
Sat, 9 Nov 2019 20:38:08 +0000 (15:38 -0500)
Signed-off-by: Aaron Bauman <bman@gentoo.org>
dev-tex/leaflet/leaflet-20041222.ebuild

index d7c1e7727d42b84abb7d369d604355c3b7a324d3..291b64a2ef8d56164a30a30d7a984f8347c563d1 100644 (file)
@@ -1,31 +1,29 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=0
+EAPI=7
 
-inherit latex-package eutils
-
-S=${WORKDIR}/leaflet
+inherit latex-package
 
 DESCRIPTION="LaTeX package used to create leaflet-type brochures"
+HOMEPAGE="https://www.ctan.org/tex-archive/macros/latex/contrib/leaflet/"
 SRC_URI="mirror://gentoo/${P}.zip"
-HOMEPAGE="http://www.ctan.org/tex-archive/macros/latex/contrib/leaflet/"
+# checksum from official ftp site changes frequently so we mirror it
+
+KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~mips ppc ppc64 s390 sh sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
 
 LICENSE="LPPL-1.3"
 SLOT="0"
-KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~mips ppc ppc64 s390 sh sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
 IUSE=""
 
-# checksum from official ftp site changes frequently so we mirror it
+RDEPEND="dev-texlive/texlive-fontsrecommended"
+DEPEND="${RDEPEND}
+       app-arch/unzip
+"
+
+DOCS=( "README" )
+PATCHES=( "${FILESDIR}/${P}-logging.patch" )
 
 TEXMF="/usr/share/texmf-site"
 
-RDEPEND="dev-texlive/texlive-fontsrecommended"
-DEPEND="${RDEPEND} app-arch/unzip"
-DOCS="README"
-
-src_unpack() {
-       unpack ${A}
-       cd "${S}"
-       epatch "${FILESDIR}/${P}-logging.patch"
-}
+S=${WORKDIR}/leaflet