dev-python/sphinxcontrib-github-alt: bump to 1.1
authorVirgil Dupras <vdupras@gentoo.org>
Sat, 4 May 2019 20:45:12 +0000 (16:45 -0400)
committerVirgil Dupras <vdupras@gentoo.org>
Sat, 4 May 2019 22:58:03 +0000 (18:58 -0400)
Also, drop py2

Bug: https://bugs.gentoo.org/685040
Signed-off-by: Virgil Dupras <vdupras@gentoo.org>
Package-Manager: Portage-2.3.62, Repoman-2.3.11

dev-python/sphinxcontrib-github-alt/Manifest
dev-python/sphinxcontrib-github-alt/files/sphinxcontrib-github-alt-1.1-setup.py.patch [new file with mode: 0644]
dev-python/sphinxcontrib-github-alt/sphinxcontrib-github-alt-1.1.ebuild [new file with mode: 0644]

index e920d1f03a0536131866ccff8448ff2eda128256..b291ce0791ca3708287030f45470cfcf437f2b7e 100644 (file)
@@ -1 +1,2 @@
 DIST sphinxcontrib-github-alt-1.0.tar.gz 3213 BLAKE2B b2449c0b635769735a23187f422f05c21c52098bd25057f4dfec5412040992417451ba21bd85dcdd71c75fe2d0ac935f745b6595bf5c77bb3facf91d48a39cef SHA512 57f5ab3a5d679634ce0c2ea8c78069f37ed5a5d3c32fe6cf61851ed4a9e8b6b9b6c882f486eb84914153b4121dacc25fd4b11edee111630001ae9bc324f2250e
+DIST sphinxcontrib-github-alt-1.1.tar.gz 3312 BLAKE2B 4665c873bff44a65b0aaac4ea853ac4edc3447850f6c18a8c7b717a84e158c6cf0c16116bbfdff8f3419b8448272a180c57283c324ab5052359da4522937abbf SHA512 b7af74e3762d51663bcc8a33d10bb63ae5fd24e220919719de5ff9421ec2ae854b84bb9f17f379fa174996edc2160580fb49b0030bab4cadbdfbcbf0a0cd509d
diff --git a/dev-python/sphinxcontrib-github-alt/files/sphinxcontrib-github-alt-1.1-setup.py.patch b/dev-python/sphinxcontrib-github-alt/files/sphinxcontrib-github-alt-1.1-setup.py.patch
new file mode 100644 (file)
index 0000000..37269d0
--- /dev/null
@@ -0,0 +1,19 @@
+setup.py for sphinxcontrib_github_alt by Marius Brehler <marbre@linux.sungazer.de>.
+
+Patch by Marius Brehler <marbrbre@linux.sungazer.de>.
+--- /dev/null
++++ b/setup.py
+@@ -0,0 +1,12 @@
++from distutils.core import setup
++
++setup(name='sphinxcontrib_github_alt',
++      version='1.1',
++      author='Jupyter Development Team',
++      author_email='jupyter@googlegroups.com',
++      url='https://github.com/jupyter/sphinxcontrib_github_alt',
++      packages=['sphinxcontrib_github_alt'],
++      classifiers=[
++          'License :: OSI Approved :: BSD License'
++      ]
++)
+\ No newline at end of file
diff --git a/dev-python/sphinxcontrib-github-alt/sphinxcontrib-github-alt-1.1.ebuild b/dev-python/sphinxcontrib-github-alt/sphinxcontrib-github-alt-1.1.ebuild
new file mode 100644 (file)
index 0000000..e26121e
--- /dev/null
@@ -0,0 +1,35 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{5,6,7} )
+
+inherit distutils-r1
+
+MY_PN="sphinxcontrib_github_alt"
+
+DESCRIPTION="Link to GitHub issues, pull requests, commits and users from Sphinx docs"
+HOMEPAGE="https://github.com/jupyter/sphinxcontrib_github_alt"
+SRC_URI="https://github.com/jupyter/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="
+       dev-python/sphinx[${PYTHON_USEDEP}]"
+
+PATCHES=(
+       "${FILESDIR}/${PN}"-1.1-setup.py.patch
+       "${FILESDIR}/${PN}"-1.0-init.py.patch
+)
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+python_prepare_all() {
+       distutils-r1_python_prepare_all
+
+       mv "${WORKDIR}/${MY_PN}-${PV}"/sphinxcontrib_github_alt.py "${WORKDIR}/${MY_PN}-${PV}/${MY_PN}/" || die
+}