app-eselect/eselect-postgresql: Bump to 2.3
authorAaron W. Swenson <titanofold@gentoo.org>
Sun, 14 Jan 2018 18:25:05 +0000 (13:25 -0500)
committerAaron W. Swenson <titanofold@gentoo.org>
Sun, 14 Jan 2018 18:25:33 +0000 (13:25 -0500)
ln now tries to force the link (Thanks Matthew Thode [prometheanfire])

Cleans up nonsensical links in /usr/include/postgresql-* that were
made by some previous versions of this module.

Bug: https://bugs.gentoo.org/627476
Bug: https://bugs.gentoo.org/631936
Bug: https://bugs.gentoo.org/640154
Bug: https://bugs.gentoo.org/640394
Package-Manager: Portage-2.3.13, Repoman-2.3.3

app-eselect/eselect-postgresql/Manifest
app-eselect/eselect-postgresql/eselect-postgresql-2.3.ebuild [new file with mode: 0644]

index 7777d3dbb48346fe5afa28ac861d85afe08ca1e7..1420594ea6cc06e49cb9edb1543cab105324c488 100644 (file)
@@ -2,3 +2,4 @@ DIST eselect-postgresql-1.2.1.tbz2 3645 BLAKE2B 17262fa368b30142599145b8d0afcdb4
 DIST eselect-postgresql-2.0.tbz2 4326 BLAKE2B fb363882d283c7c212a9eb546659213750037dda9aa15d31e3feaa1f58083beaf050594f7a70255f10829a3bbb15f9748b724dc3fce1d94adc2f6681816ac606 SHA512 bc72d752bc4b2d8f3c255d446253143ff0036f6ca1a0c10eb19e23b8242bd5a912272298034279a6f9ca50c13fccbb6b89c79ed647f762a2ccb36f416060cd87
 DIST eselect-postgresql-2.1.tbz2 4404 BLAKE2B 3b7a7d20cc715a748d45fdf182c35c6a0dab1808c643a5a3de1436e01f40863b0e421b1d4717388da401a133f64c94810bafdb318409254edd27daa06ed35ef1 SHA512 83050da6ec5f5f4ae20230cdffebbb78f9335cbcbb3bc1bd38279188f0dedcf828d80aeac3c75629605cdde0b2d1d74d8ef81e9cd9a8faacc7dba2f15beb3af0
 DIST eselect-postgresql-2.2.tbz2 4428 BLAKE2B f18b7daaccb9ab2fe08bb6e7f88dd41dcdf69b951a3c20b65ee2955ff33fc614e5740ddbbe8eb8f55d20f5705d47fb2da8c3f3fc89e403ea24eb4b8d912404a0 SHA512 2a0b9b3c8c75792fb6b6f90f034562a3bef7c9391cac0d7c95a6a86db38b4c9840fce2fa0edb32b745905f974920ee1ce5dfb21d33f22c79d1bc776e013edf76
+DIST eselect-postgresql-2.3.tbz2 4526 BLAKE2B 226f2be462d54d835cc884f6b2c33e0f84d4500e19251fb6794929901ec033e0fa457d8606e36ada462d538674110ba8aab901ca9f86dccd52ccf9c860ba5ce1 SHA512 d7f87aa3e21c5e35f3a6879bdfb9404a2884f761463f77952f21c522b1605f191385ba7b4758548b121ad7eb56d395163e0d6bba57df446be515e6d7163635b4
diff --git a/app-eselect/eselect-postgresql/eselect-postgresql-2.3.ebuild b/app-eselect/eselect-postgresql/eselect-postgresql-2.3.ebuild
new file mode 100644 (file)
index 0000000..7545dbe
--- /dev/null
@@ -0,0 +1,34 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Utility to select the default PostgreSQL slot"
+HOMEPAGE="https://www.gentoo.org/"
+SRC_URI="https://dev.gentoo.org/~titanofold/${P}.tbz2"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~ppc-macos ~x86-solaris"
+
+RDEPEND="app-admin/eselect"
+
+# All dev-db/postgresql ebuilds from 10.0 on are well supported. Earlier
+# ebuilds may present some quality of life issues.
+PDEPEND="
+       !<dev-db/postgresql-9.6.2-r1:9.6
+       !<dev-db/postgresql-9.5.6-r1:9.5
+       !<dev-db/postgresql-9.4.11-r1:9.4
+       !<dev-db/postgresql-9.3.16-r1:9.3
+       !<dev-db/postgresql-9.2.20-r1
+"
+
+src_install() {
+       insinto /usr/share/eselect/modules
+       doins postgresql.eselect
+
+       dosym eselect /usr/bin/postgresql-config
+}
+
+pkg_postinst() {
+       postgresql-config update
+}