dev-ros/gazebo_plugins: Add python 3.4/3.5 support and missing PYTHON_USEDEP on some...
authorAlexis Ballier <aballier@gentoo.org>
Tue, 21 Feb 2017 09:04:40 +0000 (10:04 +0100)
committerAlexis Ballier <aballier@gentoo.org>
Tue, 21 Feb 2017 09:21:13 +0000 (10:21 +0100)
Package-Manager: Portage-2.3.3, Repoman-2.3.1

dev-ros/gazebo_plugins/gazebo_plugins-2.6.2.ebuild
dev-ros/gazebo_plugins/gazebo_plugins-9999.ebuild

index ab8d4d467e106bc140a1e4ad6c91956503885d1d..c2245b9b1082ab59c5d70a5b13e4505ccf93e76e 100644 (file)
@@ -5,7 +5,7 @@
 EAPI=5
 ROS_REPO_URI="https://github.com/ros-simulation/gazebo_ros_pkgs"
 KEYWORDS="~amd64"
-PYTHON_COMPAT=( python2_7 )
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
 CATKIN_HAS_MESSAGES=yes
 ROS_SUBDIR=${PN}
 
@@ -29,8 +29,8 @@ RDEPEND="
        dev-ros/urdf
        dev-ros/tf
        dev-ros/tf2_ros
-       dev-ros/dynamic_reconfigure
-       dev-ros/driver_base
+       dev-ros/dynamic_reconfigure[${PYTHON_USEDEP}]
+       dev-ros/driver_base[${PYTHON_USEDEP}]
        dev-ros/rosgraph_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
        dev-ros/trajectory_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
        dev-ros/pcl_conversions
index 2c0abf6a639e4ea11d08c8f8bdf8f78a2266ea49..c2245b9b1082ab59c5d70a5b13e4505ccf93e76e 100644 (file)
@@ -1,11 +1,11 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 # $Id$
 
 EAPI=5
 ROS_REPO_URI="https://github.com/ros-simulation/gazebo_ros_pkgs"
 KEYWORDS="~amd64"
-PYTHON_COMPAT=( python2_7 )
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
 CATKIN_HAS_MESSAGES=yes
 ROS_SUBDIR=${PN}
 
@@ -29,8 +29,8 @@ RDEPEND="
        dev-ros/urdf
        dev-ros/tf
        dev-ros/tf2_ros
-       dev-ros/dynamic_reconfigure
-       dev-ros/driver_base
+       dev-ros/dynamic_reconfigure[${PYTHON_USEDEP}]
+       dev-ros/driver_base[${PYTHON_USEDEP}]
        dev-ros/rosgraph_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
        dev-ros/trajectory_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
        dev-ros/pcl_conversions