dev-games/aseprite: update to 1.1.9
authorAzamat H. Hackimov <azamat.hackimov@gmail.com>
Tue, 17 Mar 2020 18:45:49 +0000 (21:45 +0300)
committerJoonas Niilola <juippis@gentoo.org>
Wed, 25 Mar 2020 11:17:04 +0000 (13:17 +0200)
Update to 1.1.9. This version now uses own EULA license.
Minor fixes to ebuild: switch to EAPI 7 and cmake eclass.

Package-Manager: Portage-2.3.89, Repoman-2.3.20
Signed-off-by: Azamat H. Hackimov <azamat.hackimov@gmail.com>
Signed-off-by: Joonas Niilola <juippis@gentoo.org>
dev-games/aseprite/Manifest
dev-games/aseprite/aseprite-1.1.9.ebuild [new file with mode: 0644]

index 06dcddff4476d479f0b294593c7303248c419300..ef78558093984b9eceda2c46ab1c7528fdf1912e 100644 (file)
@@ -1,2 +1,3 @@
 DIST Aseprite-v1.1.6-Source.zip 11801981 BLAKE2B f20186a1669d7f9ab1453a2104a54228c22e2ef1703bba200f44c965b3fb3d9310c1ddd343db9c27ddca3564e4245352476c5228e171f1c0e74c553e5a59d419 SHA512 d87bcc5ece64cbc772ea5d4dc1edf29943d9038221905c0263511852afbb4e9119ce82468502a78c286729bb91389d08e3a8b7f358e4f6f8fe88507e7e69c9ac
 DIST Aseprite-v1.1.7-Source.zip 11801711 BLAKE2B 282492c29ece6b5b5bed029c7f27aa0a287bcb475f60066b6c34f54607b2714f35540e4d6ef4737818712776c2202162ce47c5713ba26b756d9e1c1d8af9c904 SHA512 9a92853042c7de567a7eb33d10ddd38c6d6bd53acfe4b93dc96e11408a7bda39ef7503c159934c483f0455700933c541dfdc0cb4c505d3385778e40686e474e6
+DIST Aseprite-v1.1.9-Source.zip 11746265 BLAKE2B fa16be059a7bb3b83705c56e7e93cbbb71676617a8d0798f0e481b09199ae069b85826615f8609acabb10a4e9a9da0857f2f99b03c2b913f26eee6d4dfdc0f0a SHA512 44c5878c67e69d2510c862e8f6869d727aa47b3d23d41d4e7318eca54c6d72fc5f89e72c70c160ce6da78fa091e11eedefa74e0273dc4cea59b2fe16c8851d9e
diff --git a/dev-games/aseprite/aseprite-1.1.9.ebuild b/dev-games/aseprite/aseprite-1.1.9.ebuild
new file mode 100644 (file)
index 0000000..8665940
--- /dev/null
@@ -0,0 +1,111 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake desktop flag-o-matic
+
+DESCRIPTION="Animated sprite editor & pixel art tool"
+HOMEPAGE="https://www.aseprite.org"
+SRC_URI="https://github.com/aseprite/aseprite/releases/download/v${PV}/Aseprite-v${PV}-Source.zip"
+
+# See https://github.com/aseprite/aseprite#license
+# Some bundled third-party packages built-in:
+# gtest duktape modp_b64 simpleini
+LICENSE="Aseprite-EULA"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="bundled-libs debug kde gtk3 test webp"
+RESTRICT="bindist mirror !test? ( test )"
+
+RDEPEND="
+       !bundled-libs? ( media-libs/allegro:0[X,png] )
+       gtk3? ( dev-cpp/gtkmm:3.0 )
+       kde? (
+               dev-qt/qtcore:5
+               kde-frameworks/kio:5
+       )
+       webp? ( media-libs/libwebp )
+       dev-libs/tinyxml
+       media-libs/freetype
+       media-libs/giflib:=
+       media-libs/libpng:0=
+       net-misc/curl
+       sys-libs/zlib
+       virtual/jpeg:0
+       x11-libs/libX11
+       x11-libs/pixman"
+BDEPEND="
+       app-arch/unzip
+       gtk3? ( virtual/pkgconfig )
+       webp? ( virtual/pkgconfig )"
+
+DOCS=( docs/files/ase.txt
+       docs/files/fli.txt
+       docs/files/msk.txt
+       docs/files/pic.txt
+       docs/files/picpro.txt
+       README.md )
+
+S="${WORKDIR}"
+
+PATCHES=( "${FILESDIR}/${PN}-1.1.7_type-punned_pointer.patch" )
+
+src_prepare() {
+       cmake_src_prepare
+
+       # Fix to make flag-o-matic work.
+       if use debug ; then
+               sed -i '/-DNDEBUG/d' CMakeLists.txt || die
+       fi
+       # Fix shebang in thumbnailer
+       sed -i -e 's:#!/usr/bin/sh:#!/bin/sh:' desktop/aseprite-thumbnailer || die
+}
+
+src_configure() {
+       use debug && append-cppflags -DDEBUGMODE -D_DEBUG
+
+       local mycmakeargs=(
+               -DENABLE_UPDATER=OFF
+               -DFULLSCREEN_PLATFORM=ON
+               -DUSE_SHARED_ALLEGRO4=$(usex !bundled-libs)
+               -DUSE_SHARED_CURL=ON
+               -DUSE_SHARED_FREETYPE=ON
+               -DUSE_SHARED_GIFLIB=ON
+               -DUSE_SHARED_JPEGLIB=ON
+               -DUSE_SHARED_LIBLOADPNG=ON
+               -DUSE_SHARED_LIBPNG=ON
+               -DUSE_SHARED_PIXMAN=ON
+               -DUSE_SHARED_TINYXML=ON
+               -DUSE_SHARED_ZLIB=ON
+               -DUSE_SHARED_LIBWEBP=ON
+               -DWITH_DESKTOP_INTEGRATION=ON
+               -DWITH_GTK_FILE_DIALOG_SUPPORT="$(usex gtk3)"
+               -DWITH_QT_THUMBNAILER="$(usex kde)"
+               -DWITH_WEBP_SUPPORT="$(usex webp)"
+               -DENABLE_TESTS="$(usex test)"
+               -DKDE_INSTALL_USE_QT_SYS_PATHS=ON
+       )
+       cmake_src_configure
+}
+
+src_install() {
+       newicon -s 64 "${S}/data/icons/ase64.png" "${PN}.png"
+       cmake_src_install
+}
+
+pkg_postinst() {
+       if use !bundled-libs ; then
+               ewarn "Aseprite has been built with system-wide Allegro 4."
+               ewarn "Please note that you will not be able to resize the main window."
+               ewarn "For resizing support enable USE-flag bundled-libs and rebuild package."
+       fi
+       xdg_desktop_database_update
+       xdg_mimeinfo_database_update
+}
+
+pkg_postrm() {
+       xdg_desktop_database_update
+       xdg_mimeinfo_database_update
+}