sys-cluster/neutron: switch most to python_install_all
authorMatthew Thode <prometheanfire@gentoo.org>
Wed, 30 Nov 2016 05:14:40 +0000 (23:14 -0600)
committerMatthew Thode <prometheanfire@gentoo.org>
Wed, 30 Nov 2016 05:18:10 +0000 (23:18 -0600)
Package-Manager: portage-2.3.0

sys-cluster/neutron/neutron-2016.2.9999.ebuild

index 92c35823b9e631397d9cbb817cf0dbd9500644f9..5f78ccc3e21f58bb600d9487791dd644ffb7ab57 100644 (file)
@@ -128,7 +128,7 @@ RDEPEND="
 #PATCHES=(
 #)
 
-pkg_setup() {
+pkg_pretend() {
        linux-info_pkg_setup
        CONFIG_CHECK_MODULES="VLAN_8021Q IP6_NF_FILTER IP6_NF_IPTABLES IP_NF_TARGET_REJECT \
        IP_NF_MANGLE IP_NF_TARGET_MASQUERADE NF_NAT_IPV4 NF_CONNTRACK_IPV4 NF_DEFRAG_IPV4 \
@@ -138,6 +138,9 @@ pkg_setup() {
                        linux_chkconfig_present ${module} || ewarn "${module} needs to be enabled in kernel"
                done
        fi
+}
+
+pkg_setup() {
        enewgroup neutron
        enewuser neutron -1 -1 /var/lib/neutron neutron
 }
@@ -154,8 +157,8 @@ src_prepare() {
        distutils-r1_python_prepare_all
 }
 
-python_install() {
-       distutils-r1_python_install
+python_install_all() {
+       distutils-r1_python_install_all
        if use server; then
                newinitd "${FILESDIR}/neutron.initd" "neutron-server"
                newconfd "${FILESDIR}/neutron-server.confd" "neutron-server"
@@ -197,10 +200,6 @@ python_install() {
        doins "etc/rootwrap.conf"
        doins -r "etc/neutron/rootwrap.d"
 
-       insopts -m 0644
-       insinto "/usr/lib64/python2.7/site-packages/neutron/db/migration/alembic_migrations/"
-       doins -r "neutron/db/migration/alembic_migrations/versions"
-
        #add sudoers definitions for user neutron
        insinto /etc/sudoers.d/
        insopts -m 0440 -o root -g root
@@ -220,6 +219,14 @@ python_install() {
        rm -R "${D}/usr/etc/"
 }
 
+python_install() {
+       distutils-r1_python_install
+       # copy migration conf file (not coppied on install via setup.py script)
+       insopts -m 0644
+       insinto "/$(python_get_sitedir)/neutron/db/migration/alembic_migrations/"
+       doins -r "neutron/db/migration/alembic_migrations/versions"
+}
+
 pkg_postinst() {
        elog
        elog "neutron-server's conf.d file may need updating to include additional ini files"