dev-python/pexpect: Clean old up
authorMichał Górny <mgorny@gentoo.org>
Fri, 5 Jan 2018 17:19:45 +0000 (18:19 +0100)
committerMichał Górny <mgorny@gentoo.org>
Fri, 5 Jan 2018 23:18:49 +0000 (00:18 +0100)
dev-python/pexpect/Manifest
dev-python/pexpect/pexpect-3.3.ebuild [deleted file]

index 7aefda21bfe0f5f91ab90fba7fcf7b4e7631fbfd..f4c41a9c88ca154434b42770dc41a14ba3c18ff5 100644 (file)
@@ -1,2 +1 @@
-DIST pexpect-3.3.tar.gz 132330 BLAKE2B 3dcbc10aa6029fdcc7930bca355583c146661d21820f2fafa2886bfe130c2c0d632bf9edfa5f96f5eae68b5dc7202e1d4bdcc3ea8593ee98346cdd7c354b6ac9 SHA512 66cc501f1c7bb8ba0be4cdc0db840629f51416dc54ae44dc770adb38f1a385116b0a8b9bc7f1cc1447f05ede36ef1b519f5c4e710e6cb736c923ecfc87497cfa
 DIST pexpect-4.2.1.tar.gz 143980 BLAKE2B b5cb9c7847eabdf8778bddc6b208520edb9b3611d7a981fae6e371fa6deafebe142ba8361e3a1d21187cd692576c91d732f3def75e19989296f50b2a9fb4d4c6 SHA512 796474c87559cb9f4e2dfe72564d70c75e1aac4f57c4f3e4033a56c8842a48380ae0d5fafdad7f1ea6718b25c272fe4a611a59db44e69afb1f2bbf7e00256261
diff --git a/dev-python/pexpect/pexpect-3.3.ebuild b/dev-python/pexpect/pexpect-3.3.ebuild
deleted file mode 100644 (file)
index 92cc05f..0000000
+++ /dev/null
@@ -1,36 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy pypy3 )
-PYTHON_REQ_USE="threads(+)"
-
-inherit distutils-r1
-
-DESCRIPTION="Python module for spawning child applications and responding to expected patterns"
-HOMEPAGE="http://pexpect.sourceforge.net/ https://pypi.python.org/pypi/pexpect/ https://github.com/pexpect/pexpect/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="alpha amd64 arm arm64 hppa ia64 ~mips ppc ppc64 s390 sh sparc x86 ~amd64-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
-IUSE="doc examples test"
-
-DEPEND="
-       doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
-       test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
-
-python_compile_all() {
-       use doc && emake -C doc html
-}
-
-python_test() {
-       py.test tests || die "Tests fail with ${EPYTHON}"
-}
-
-python_install_all() {
-       use doc && local HTML_DOCS=( doc/_build/html/. )
-       use examples && local EXAMPLES=( examples/. )
-       distutils-r1_python_install_all
-}