dev-ruby/fakeweb: avoid network tests
authorHans de Graaff <graaff@gentoo.org>
Thu, 21 May 2020 05:22:30 +0000 (07:22 +0200)
committerHans de Graaff <graaff@gentoo.org>
Sat, 23 May 2020 05:27:48 +0000 (07:27 +0200)
Closes: https://bugs.gentoo.org/723808
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
dev-ruby/fakeweb/fakeweb-1.3.0.20170806.ebuild

index 94a8307834a1f4b234960c3f5f74333fbcad35d7..99dd3e6ce4b74920c046089961a19af59ae97061 100644 (file)
@@ -1,10 +1,10 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=6
 
 # ruby26: not compatible
-USE_RUBY="ruby23 ruby24 ruby25"
+USE_RUBY="ruby24 ruby25"
 
 RUBY_FAKEGEM_RECIPE_DOC="rdoc"
 RUBY_FAKEGEM_EXTRADOC="CHANGELOG README.rdoc"
@@ -46,4 +46,7 @@ all_ruby_prepare() {
        rm test/test_other_net_http_libraries.rb || die
 
        sed -i -e '/test:preflight/ s:^:#:' Rakefile || die
+
+       # Avoid tests that require a network connection
+       sed -i -e '/test_real_https_request/aomit "requires network"' test/test_fake_web.rb || die
 }