dev-python/pygments: Port to py39
authorMichał Górny <mgorny@gentoo.org>
Tue, 26 May 2020 12:18:52 +0000 (14:18 +0200)
committerMichał Górny <mgorny@gentoo.org>
Tue, 26 May 2020 12:58:28 +0000 (14:58 +0200)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/pygments/pygments-2.5.2.ebuild
dev-python/pygments/pygments-2.6.1.ebuild

index 4f0d6aff821c72ef07565d4b0957bdb1c422ac94..8771025bd72adc0ddd88be6356e89134eb656efe 100644 (file)
@@ -4,7 +4,7 @@
 EAPI=7
 
 DISTUTILS_USE_SETUPTOOLS=rdepend
-PYTHON_COMPAT=( python2_7 python3_{6,7,8} pypy3 )
+PYTHON_COMPAT=( python2_7 python3_{6,7,8,9} pypy3 )
 
 inherit distutils-r1 bash-completion-r1
 
@@ -32,7 +32,7 @@ distutils_enable_sphinx doc
 
 python_test() {
        cp -r -l tests "${BUILD_DIR}"/ || die
-       pytest "${BUILD_DIR}"/tests || die "Tests fail with ${EPYTHON}"
+       pytest -vv "${BUILD_DIR}"/tests || die "Tests fail with ${EPYTHON}"
 }
 
 python_install_all() {
index eef8f5251bf81d67df8619b84e014e274d41e1f8..89bb177bba44d3b33d5d7b0cd2c956561ccbbf8b 100644 (file)
@@ -4,7 +4,7 @@
 EAPI=7
 
 DISTUTILS_USE_SETUPTOOLS=rdepend
-PYTHON_COMPAT=( python3_{6,7,8} pypy3 )
+PYTHON_COMPAT=( python3_{6,7,8,9} pypy3 )
 
 inherit distutils-r1 bash-completion-r1